UiPath Enterprise version 2021 fails with message "Machine Level installs are not permitted"

I downloaded UiPath 2021 msi installer file and tried installing in my local machine, I have ensured that I have uninstalled my previous version of UiPath including assistant and everything. while trying to install I am getting the below error message.
"Machine level installs are not permitted while atleast one user-scoped installation exists.(user : NT Authority/System).

Could someone help fixing this issue ?

Hello @Sekar_Sundar Ref to the below thread. Please reboot your server after removing leftover files and try to install it again

1 Like

Hi @ushu I am installing in my local laptop only and I tried restarting the machine , deleting all previous installation files and everything. still I am getting the same while trying to install the Enterprise edition , where as If I install Community Edition using the same msi file , it is getting installed. But I am trying to install the Enterprise Edition .

Hi @Sekar_Sundar

This is just to check whether you were able to solve this issue. If not, we would like to collect some more information and make sure this is not an issue for anyone :slight_smile:

I had a similar problem. Excerpts from log file:

Running custom action DetectRelatedProductsCA as user ABC\myuser
Installed versions info:
ProductCode: {DC3FFE5F-7933-40E8-A539-7EC0625C77ED}
Installed: False
Elevated: True

User-level installs are not permitted while a machine-scoped installation exists.
Telemetry.DesktopMsiInstaller.End - Sent:False

Tutorial posted before actually should solve the problem. Support manager helped me solve it by clearing temp files from another installation which prevented installing a new version.