UiPath Enterprise 19.10.5 (onprem) and Elasticsearch 7.5.1, no data getting pushed into Elasticsearch

I’m struggling with UiPath 19.10.5 and getting Orchestrator to push log data into Elasticsearch 7.5.1 for Robot logs.

The installation docs requirement just says Elasticsearch 7.#. Notice the pound symbol. I’ve done a little backwards checking. I’ve run a very simple hello work type workflow in Studio. When I had the Robot logs going into the DB, the simple log entries showed up in the Log web page from the DB. Now, I’ve switched the config over to using ElasticSearch for Robot logs. And I’ve run the same Studio workflow and … nothing showing up in the Orchestrator Logs page and nothing shows up in Elasticsearch/Kibana either.

I’ve have done some diagnostics using tshark on the load balancer I have in front of Elasticsearch which has a basic config with no authentication required. The layout is one master and two master/data/ingest nodes on port 9200. Web.config is configured to hit the LB VIP for Elasticsearch going to the two master/data/ingest nodes. The LB is Nginx. This Nginx config appears to be working fine as I have Kibana using the same LB VIP and it doesn’t complain at all.

  1. When the Robot runs the workflow and completes, there is NO tcp traffic on port 9200 between Orchestrator and the load balancer.
  2. Elasticsearch does not contain an index for the current Tenant the Robot is running under which is “pi-notclustered”
  3. When I go in the Logs page and/or do a Logs page refresh, I do get tcp traffic in tshark on port 9200 between Orchestrator and the Load Balancer. The query going to Elastic looks to be this: POST /pi-notclustered-%2A/_search?typed_keys=true

In #3, that looks correct as the Tenant I’m working under is “pi-notclustered”.

I have even published the simple workflow to Orchestrator and run it from Orchestrator so my local Robot displays the message. Same results. No traffic on port 9200 between Orchestrator and the LB VIP for Elasticsearch.

So my question is why isn’t there any traffic going in this direction: Robot -> Orchestrator -> Web.config(robotElasticBuffer) -> Elasticsearch to create the pi-notclustered-yyyy.MM index and push data into it ?

I want to scream. I did not pay attention to what a URI contains … like the protocol. I just had to “http://” in front of the uri= parameter for the Elasticsearch target definition. Ugh …

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.