UIPath crash during Library Publishing

Hi Pablito.

In the “event viewer” I found 2 error (see below).
No, at the moment I don’t know how to check on other computers.

  • .NET runtime

Application: UiPath.ActivityCompiler.CommandLine.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.AccessViolationException
at .VbHostedCompiler.{dtor}(VbHostedCompiler*)
at .Microsoft.Compiler.VisualBasic.CompilerBridge.__vecDelDtor(Microsoft.Compiler.VisualBasic.CompilerBridge*, UInt32)
at Microsoft.Compiler.VisualBasic.HostedCompiler.!HostedCompiler()
at Microsoft.Compiler.VisualBasic.HostedCompiler.Dispose(Boolean)
at Microsoft.Compiler.VisualBasic.HostedCompiler.Finalize()

  • Application Error

Faulting application name: UiPath.ActivityCompiler.CommandLine.exe, version:, time stamp: 0x5ce434bd
Faulting module name: Microsoft.VisualBasic.Activities.Compiler.dll, version: 14.7.2556.0, time stamp: 0x59b8410b
Exception code: 0xc0000005
Fault offset: 0x000a6aa2
Faulting process id: 0xb088
Faulting application start time: 0x01d5227df8c5ddb1
Faulting application path: c:\users\xxxxxx\appdata\local\uipath\app-19.5.0\UiPath.ActivityCompiler.CommandLine.exe
Faulting module path: C:\WINDOWS\Microsoft.Net\assembly\GAC_32\Microsoft.VisualBasic.Activities.Compiler\v4.0_10.0.0.0__b03f5f7f11d50a3a\Microsoft.VisualBasic.Activities.Compiler.dll
Report Id: 82d41eee-cfb6-4244-a038-d96e571cfc69
Faulting package full name:
Faulting package-relative application ID:

Are you using any non-standard packages in your projects?
There was similar issue couple months ago:

Yes, I am using a my library import as package in the other library.

Hmmm, not sure but this might cause the problem here.

I think yes.

  • The two Library working fine separately
  • In the UIPath EXECUTE, i run the second Library with call at the first Library and working fine

In the dependancies of second library, the first is present.

The compiler log end successfully.
The crash, i think, happens when the file .nupkg has to be written

If you using Community Edition you could try switch to BetaChannel and check if with the newest version the problem is the same.

1 Like

Another bit.

In the log i found this row

COMPILER: Writing assembly to file ‘C:\Users\xxx\Documents\UiPath\PulseConnect\PulseConnect.dll’

But PulseConnect.dll not created

Ok, this is very strange for me.

This is the my library flow.

The “GetCredential” is a library imported from Packages.
In this configuration the publish crash

I did several tests.

If I remove “GetCredential” activity from flow (but not from dependencies) the publish works

If I remove “Get Config” activity from flow the publish works

If I disconnect “GetCredential” activity from flow (without remove) the publish crash

If I disconnect any part of flow before “Get Config” the publish works!

The conflict it’s between Get Config and GetCredential.
But the Get Config is simple read and deserialized JSON file

Hmm what about variable types? I guess your workflow will connect somewhere based on this:image.
Are you keeping the password from deserialized Json as a SecureString type?

Not sure if this is the cause but I meet many issues related to this kind of mistakes.

Hi restrict the problem in “Deserialized JSON”.
If I comment this activity the publish works.

At this point the conflict is between Deserialized JSON and Get Credentials, individually they work, but together no.

Yes, I use SecurityString in Get Credential to retrieve the password.
In Deserialized JSON I get only the key in order to get user and password from Windows Credential.

Hi @MarcoM

Just an idea - do the libraries have the same dependencies installed?
As in - does the VPN library has all the dependencies used in the Credential library?

Is it also true for the namespaces?

I restricted the problem further.
I have created a simple flow


All works until I insert variable Newtonsoft.Json.Linq.JObject in deserializedJson activity.
If I leave empty the JsonObject in the Output section, the publish work.
But if I use the decodingJSON variable, the publish crash until I don’t remove the my GetCredential library…

Just an idea - do the libraries have the same dependencies installed?
As in - does the VPN library has all the dependencies used in the Credential library?

Is it also true for the namespaces?

I have chek all libraries, dependencies and version, are all the same.
In the get credential I don’t use DeserializedJSON, only UIPath official getSecureCredential in simple a flow to manage new credential if a key not found.

Could you make sure the namespace is available in both projects?

Just to be sure.

Also, any chance you could share your project or let us know the version of your Studio and all the packages that are being used?

Ok, in the GetCredential i have only Newtonsoft.Json

In the test flow I have Newtonsoft.Json and Newtonsoft.Json,Linq

You think this is the problem?
In the getCredential i don’t use JSON.

The my UIPath is

2019.5.0 - 5/21/2019
Community Edition

Microsoft Windows 10 Enterprise 64-bit
.NET Framework Version 4.7.1

I share my project as soon possible


You can try adding the missing namespace and restart Studio just to see if it fixes it.

No, the issue remains.
In attached files the GetCredential library and the simple flow with DeserializedJSON and GetCredential.
Are only xaml files sufficient?

NewActivity.xaml (4.7 KB) GetCredential.xaml (18.1 KB)


I have try to import the workflow (GetCredential.xaml) in the project and the publish works.
But in this case I don’t understand the library and the import through the package

Hi @MarcoM

Our team managed to reproduce the bug and it will most likely be fixed in the next Community version. Thank you for reporting it! :slight_smile:

1 Like

Hi, I’m getting the same error when publishing a custom library that also uses both the Deserialize JSON and Get Credential activities. I’m using Studio 2019.4.4 Enterprise Edition. Any update on this?

1 Like