UiPath complaining that "work item status not provided"


I’ve got an issue with UiPath Studio. I haven’t found a solved issue on this forum similar to it, if there is, I’d like to know. What’s going on is that I’m in the process of updating a work item status on a particular page and when I run the workflow UiPath complains that the work item status was not provided. Here are the screenshots:

This above screenshot is of UiPath throwing the exception.

I thought about this and wondered if maybe I have the activity that checks for the work item status in the wrong place in the workflow, but the UiPath course I’m following makes it seem that isn’t the issue. Has somebody come across this kind of thing before?

Thank you in advance.

(post deleted by author)

I just remembered to say I’m using UiPath Studio Community 2021.10.3.

Can you show as full condition you have procided in if activity


IF you keep in_workItemStatus = “Completed”

Then the condition will become true and Then block will be executed

That’s a custom throw, so you have to fix your condition


Of course, I’ll do that asap.

The condition that is in the if activity is this:

string.IsNullOrEmpty(in_WorkItemStatus) Or in_WorkItemStatus <> “Open” Or in_WorkItemStatus <> “Completed” Or in_WorkItemStatus <> “Rejected”

I just fixed the condition. I removed the text starting with Or, took new screenshots, and it worked as needed. The only reason I had the condition as it was because the instructor in the course suggested checking if the work item status was any one of the three values listed, but he leaves that to you as the student viewing the video rather than coding it himself. Thank you for your help.

The new condition, for reference:



This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.