UiPath Compatibility with code developed on Old version


#1

Hi Everyone. So I have a process which was developed on UiPath Version : 2016.1.5973. This version of UiPath was using .NET 4.5 . Now I have updated UiPath to Version 2016.6137 and .NET 4.6 Now, when I run the same process on the newer UiPath, the activity(element exists) does not detect the elements. Any suggestion on how to solve this ?


#2

hi maxwell026
element exists activity is the only one that has issues after update?


#3

hi @maxwell026

Some activities are not backward compatible so they are working on it. i have mentioned them and they knows it. like select item activity as well so for now just replace that particular activity which is not working from the pane


#4

element exists activity should work without problems after upgrade.
we need more info to reproduce, what are you searching with this activity?


#5

Hi @Gabriel_Tatu and @aksh1yadav

I have been able to solve the problem by adding some delays.I added Timeout as 1500 ms and it worked. Thank you


#6

Hi

Why xamls created in lower version of UiPath is not forward compatible ?
Any solution ?

Thanks,
Vyshali C R


#7

well, they are. you need to be more specific.


#8

Not everything is, though - main difference is namespace changes (merge to Core created some conflicts).

We’ve had some issues with upgrading from early 2016.1 to 2016.2.62** as well, but aside from what was already reported in other threads it’s nothing that we could actually pinpoint. Which is a shame, as it boils down to trial and error with these forward migrations a lot of the times (like random selectors not working until you redo that activity… with exactly same selectors… after which it works… that’s not a reproducible error as you upgrade once :dizzy_face:).

From our experience it’s actually best to stick to exactly 1 specific version/build for a project from start to end, unless you absolutely need to upgrade (f.e. for Orchestrator compatibility), even if it’s an older one.
Maybe it’s something that we’re doing wrong, but if a workflow works reliably for months but breaks after upgrade, it’s hard to pinpoint why without knowing exact changes “under the hood”, especially if after “fixing” it looks the same :frowning:


#9

Also a link to one of my posts for future searches

https://forum.uipath.com/t/workflow-designer-encountered-problems/2848


#10

We have encountered similar problems.

We work and create Workflows with the latest version (V2017).

We also want to use those workflows in an older version (V2015) in connectionwith a 3rd party software.

When we load our Workflow files in to the older version, it indicates errors (like Open browser is not recognized).
When we load a Workflow created in the older version in our version we get similar problems (like Open browser)

We could upgrade the older version to the latest but then the Workflows created with the old version may (and I fear will) not work in the latest version.

And the 3rd party software seems to make use of theUIPath robot, which is also release dependent; Workflows made in V2017 crash using the robot V2015

Any way to solve this problem?


#11

Forwards compatibility is ok (some issues as you will have seen from my post)

Backwards compatibility is going to be much harder as you will get the same errors in the workflow (but in reverse) and also where activities no longer exist you will either have to change them or the activity won’t be possible.

I would say that upgrading the client to a newer version is a much easier option.