Uipath cannot find selector

Hello everyone, I’m new to uipath and am using the studio version. I’ve been trying to automate a data entry process on accpac using uipath. In the invoice entry window, there are a few fields that need to be filled. I extract data from an excel sheet and then try to fill them up. I tried using the “TypeInto” activity, but was given an exception of selector not found. I then tried to put a wild card in the cls part of the selector (which is the only variable part of the selector) but failed. I also tried using the “CV type into”, but encountered the same problem, and realised that I can’t even edit the selector this time. Below is an example of the error message. Is there any solution or workaround for this? Thank you!


Welcome to uipath forum

We can try with TYPE INTO ACTIVITY itself if you are able to indicate that element as individual element
Still we got an option to enter the value using these two activity

  1. First pass the input value to Activity named SET TO CLIPBOARD

  2. Then use a SEND HOT KEY activity with key as ctrl+v and indicate that field as element
    This will paste the value from clipboard

Try with this and if that doesn’t work pls share the selector you were using in Type into activity and mention the attribute that looks dynamic

Cheers @nyk

1 Like


As per the screenshot you are giving wildcard wrongly in the selector to make it as dynamic. I think you missed 0 in the cls attribute.

Try like the following cls=‘ATL*B068E8’

But usually the best practice is would be not to go with class attributes instead we can use Ui explorer to understand is there any aaname or unique attribute for this selector to make our selectors robust and error free.

Please try and let us known thanks.

1 Like


Welcome to forums

If you are able to scrape the elements directly with the application, then you can use TypeInto instead of CV activities

Also as we need to make selector more unique can you open the selector in UiExplorer and check what other tags are available

Hope this will help you


1 Like

Hi, this tip was super useful, thank you!

Hi, I was not the one who filled in that wildcard. Somehow, uipath automatically filled it up for me and I was unable to change it since I was using CV typeinto. After repairing the element using ui explorer, it somehow worked. Thank you!

Hi, thanks for trying to help. It worked after repairing the element using UI explorer.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.