UiPath cannot connect with Orchestrator when run as administrator

Hi Everyone,
I need to run the UiPath as administrator to select the elements in an App. But when I run UiPath as administrator, it cannot connect to Orchestrator.


Although a help link (Studio - Signing in to Your Account (uipath.com)) was given, I didn’t get the solution.

Sometimes I can open the UiPath as administrator with an Robot Error like below
image
In this scenario, I can select the elements in this App. But it throwed below errors when I debug it:
image

When I run it as a user other than administrator, below error was thrown:
image

It had worked yesterday! I don’t know if these errors are related to the connection with Orchestrator. I would appreciate it if you could help me solve this problem.

Hi @Li_Eric

Please check on this

Hope this helps!!

Hi @Li_Eric

If you are not able to connect with the service URL’s you can try this way:
Click on More Options=> Connect to Orchestrator=> Copy the orchestrator URL and paste it there=> Go to Machines in Tenant=> Click on Edit Machine=> Copy the ClientID/Machine Key and paste it in there. this should solve your error.

Regards

Hi @Li_Eric

You have to end the task of “UiPath.Service.UserHost.exe” in tab “details” in task manager,
then run again the UiPath as run as admin.

Hope it helps!!

Thank you lrtetala, Parvathy and mkankatala!
It worked when I end the task of “UiPath.Service.UserHost.exe”. Running UiPath as an administrator or normal user would also effect the automation that has published in Assistant even if this automation is not opened by UiPath.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.