UIPath : Cannot communicate with Internet Explorer browser

studio
error

#1

Hi,

I have seen all the forum messages and tried running regsvr32 with oleacc.dll and all that. Inspite of that, UIPath doesn’t seem to provide the sure shot solution to this.

Can some one please provide a valid and working solution to this error?
I believe the UIPath is not able to support the latest version of OLEACC.DLL file.

My UIPath version is : 2017.1.6498
OLEACC.DLL version : 7.2.15063.447 (got updated post windows 10 creators update)

Looking for genuine and working solution.

Error Message:
Main has thrown an exception

Source: Open browser

Message: Cannot communicate with Internet Explorer browser.

Exception Type: BrowserOperationException

UiPath.Core.BrowserOperationException: Cannot communicate with Internet Explorer browser. —> System.Runtime.InteropServices.COMException: Cannot communicate with Internet Explorer browser.
at UiPath.UiBrowserClass.Open(String bstrURL, UiBrowserFlags flag)
at UiPath.Core.Browser.Open(String url, Boolean privateSession, Boolean headlessSession, Boolean defaultSession)
— End of inner exception stack trace —
at UiPath.Core.Activities.ScopeActivity.EndExecute(NativeActivityContext context, IAsyncResult result)
at UiPath.Core.Activities.AsyncNativeActivity.BookmarkResumptionCallback(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkCallbackWrapper.Invoke(NativeActivityContext context, Bookmark bookmark, Object value)
at System.Activities.Runtime.BookmarkWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)


#2

Hello!

Have you tried to uncheck the “Enable Protected Mode” on Internet Options for both Intranet and Internet?

Regards,


Internet explorer -error
#3

Hi Yes,

I have unchecked both (they were unchecked by default for me). And the issue still persists. My IE version is:

image


#4

if you open a web page in IE can you select any HTML object with UiPath Studio recorder or UiExplorer tool?

Regards,
Adrian.


#5

Hi,

Thank you for the response.

I am able to proceed with select of HTML objects with UIPath studio. Only issue, is ‘open browser’ is not able to launch the IE. While there is no issue with launching Google Chrome.

Thanks.


#6

Hello!

Follow the guide below. It will solve your problem.

Regards,


#7

Hi,
I have the same Error.
Everything was ok but after instaling leatest updates to Windows 10 error appear.
I made all instructions from Internet Explorer Automation Troubleshooting guide and nothing was helpfoul.

Did you find any solution how to fix this?

Regards


#8

You could collect some low level traces while trying to automate IE and send it to us

See: https://robot.uipath.com/docs/robot-logs

Adrian.