UiPath Azure Devops Integration

Hello,

we have recently moved to the Automation Cloud, and I noticed that my deployments from DevOps, no longer automatically upgrade the package to the newest version. Is this some missing authorization or configuration?

Hi @SSavickas,

We have had the same issue. The auto upgrade to newest package version of the process fails after the recent update to the Azure DevOps UiPath Deploy. After contacting customer support the suggestion was to upgrade the Orchestrator to the newest version.

CI works great but CD for some reason fails for Orchestrator version 20.04.3 but works well in 19.10.18. Yes, we were surprised too that an older Orchestrator does not get affected by this bug.

We did get good support from UiPath shout out to @lucian but sadly the only solution to our issue is to upgrade Orchestrator version.

Thank you, the strange thing is that we are on the latest version, as we are on UiPath cloud

Same here.
My pipelines runs fine on my local Windows 10 PC

I then added a 2nd Build Agent (Windows 2019 Server) it fails:
##[error]No agent found in pool uipath which satisfies the specified demands: npm, Agent.Version -gtVersion 2.163.1

I boiled it down to a simple Yaml (below) = Build OK
Then, when adding the uiPath CLI installation, I get the error.

I’ve tried running the Build Agent as my self (Admin) as a Service “NT Authority\System”. Same issue

#===OK yaml====
trigger:
- master

pool: uipath

steps:
- script: echo Hello, world!
  displayName: 'Run a one-line script'

- script: |
    echo Add other tasks to build, test, and deploy your project.
    echo See https://aka.ms/yaml
  displayName: 'Run a multi-line script'
#=======
#=== this fails ====
trigger:
- master

pool: uipath

steps:
- script: echo Hello, world!
  displayName: 'Run a one-line script'

- script: |
    echo Add other tasks to build, test, and deploy your project.
    echo See https://aka.ms/yaml
  displayName: 'Run a multi-line script'

- task: UiPathInstallPlatform-preview@2
#=======

@ThomasStocker
I am trying to setup anyhow to input dinamically a value to Environment field.

The value as of now is fixed.

Do you have an idea how to do it ?

Basically, I am trying to pass this value from the Pipeline to the Release, but Azure does not pass variable values set directly in the the Pipeline to the Release.

Pipeline variable declaration
variables:

  • group: Project_Automations

  • name: Orchestrator_Environment

    value: ’ My Environment Value’

Release YAML
steps:

  • task: uipath.vsts-uipath-package.uipath-deploy.UiPathDeploy@2
    displayName: ‘UiPath Deploy’
    inputs:
    orchestratorConnection: ‘DEV_Orchestrator’
    packagesPath: ‘$(System.DefaultWorkingDirectory)/_CICD/CICD/Output/’
    folderName: Default
    environments: ‘My Environment Value’
    entryPoints: ‘$(System.DefaultWorkingDirectory)/_CICD/CICD/Output/’
    traceLevel: Information

This Descriptive video will help you out

Hi, how can i extract with a variable $(XXXXX) the package version? I want to include it as a tag.
thanks

I have tried and documented the steps to build the CI CD Pipeline for UiPath using the Azure DevOps as a blogpost.

Topics covered in this article -

:ballot_box_with_check: What is CI/CD in the context of RPA (Focus on UiPath)
:ballot_box_with_check: Key Concepts in Azure Pipelines
:ballot_box_with_check: Build the first pipeline to package UiPath project
:ballot_box_with_check: Different ways of UiPath CI/CD pipeline creation using Azure Extension or Pure Powershell
:ballot_box_with_check: Required configuration/ Configure the self-hosted agent
:ballot_box_with_check: Deployment to multiple environment
:ballot_box_with_check: Running Test Cases
:ballot_box_with_check: Complete working example.

You can read deatils here - Azure CI CD Pipelines for UiPath

1 Like

What solved your issue? I have tried to authenticate with external application & basic to cloud orchestrator several times and i cant seem to get it to work.

Hi
I meet this problem, happened at Test Stage, Log as below

Starting: UiPathTest

Task : UiPath Test
Description : Runs an existing test set on Orchestrator, or packages, deploys and executes test cases as a transient test set in one go, by specifying the path to a UiPath test project.
Version : 2.9.2547798
Author : UiPath
Help :

Found tool in cache: uipcli 1.0.8136-25036 x64
##[warning]Can't find loc string for key: AccountNameForApp
C:\hostedtoolcache\windows\uipcli\1.0.8136-25036\x64\uipcli.exe run D:\a_tasks\UiPathTest_edd520aa-3aec-408b-9649-642f8b920003\2.9.2547798\RunTestsOptions.json
Failed to run the command. Could not connect to Cloud Orchestrator: https://cloud.uipath.com/***, Account Name For App: ***, Application Id: ***, Application Scope(s): ***, Tenant: , Organization Unit: Modern.
Please make sure that the provided URL (https://cloud.uipath.com/
) is correct, available from your build agent, and not blocked by a firewall.
If the Orchestrator is using a self-signed SSL certificate, make sure that the build agent trusts it. Ensure that all the steps at Self-signed certificates were correctly followed when creating the certificate.
Stack trace:

BR,
Donghai

1 Like

from my experience, ‘Conflict’ means that the package you’re trying to publish already exits in Orchestrator. You need to publish a newer package and deploy.