UiPath assistant cannot acquire a license

Why your robot type is testing?

just to see what sticks. apparently nothing.

I do not even care about orchestrator, I just want to be able to write some scripts and try out some little fun things on my computer. But I cannot, because of some silly license issues.

Those are not issues. There must be something wrong with your configuration. It’s hard to see what exactly as I’m not able to see it. Try to do it step by step with documentation.

which documentation? is it possible to completely reset my data? I deleted my old tenant, created a new tenant, install the .exe multiple times, nothing works. I think the server has saved some of my old data and is getting confused. I do not mind showing you every single screen of my orchestrator (there is not much i have changed). And my studio is freely installed and cannot run, so there is nothing there

hi @ui_xpath
Seems like after you have uninstalled, you installed a newer version of Community edition, right?
Most probably you have troubling with the interactive signing
if you were able to login Machine Key instead of Service URL may the reason for that is the issue.

The new version of CE basically login through Service URL by default, you may have do do some changes to login

@Maneesha_de_silva, how do I do that? Login to the orchestrator?
(And yes, I uninstalled my enterprise studio and installed a community version. When i just started, I did not know I was using an enterprise one)

1 Like

@ui_xpath
Follow this Video, you may able to log in

2 Likes

Ok, let’s start it differently. I will show you an example based on new Modern Folders.
Remove tenant completely and Create new one and add licenses to it. Having this let’s start from Orchestrator:

  • go to tenant and create new modern folder:

    image

  • you will see that you are already added to folder but additionally you need to go to your user settings and change role to yourself:

  • click empty space next to “Administrator” and add “Robot” role:
    image

    image

  • on the tenant view go to users tab and set yourself as robot:

    I set for myself unattended one:

  • now go to your folder and navigate to settings and machines where you need to create machine template (add licenses to it):

    image

  • here is the place where you can copy the machine key:

  • having this you need to go to Assistant’s Orchestrator settings and put all needed data:
    image

  • now connect and all should be fine:
    image

1 Like

robot
thank you so much, @Pablito. I really appreciate this. However, when i got to the last step, when i tried to access Assistant’s Orchestror settings, I was not able to. Because it is not available
It is giving me that license not available message

  1. You can click Assistant icon with right mouse button on tray and select Orchestrator Settings
  2. You address is too long… remove “orchestrator_/” from it.

sorry, none of them get me the orchestrator settings. the url is automatically set. Everything is newly installed. I am not able to change anything

Go to preferences:
image
And then orchestrator settings:
image

Or just click right mouse button on tray icon as I said and select Orchestrator Settings:
image

disabled. not clickable. Sorry forgot to mention that


it says unlicensed

It might be because you passed default Wizard Connection in Assistant. Try to log off and then you should have settings available:
image

2 Likes

the same. I signed out then signed back in.

Just sign out and then go to settings where you should have possibility to choose Machine key from dropdown list and put your own settings without logon.

That was a million-dollar-support ticket. I am grateful for your patience and time and help. Thank you @Pablito so so much! thank you, @Maneesha_de_silva too.

2 Likes

I’m glad that I could help :slight_smile:
And just to be clear. The login option in Assistant is the way to automatically setup the connection when you are connecting to fresh Orchestrator - Robot instances. This allows to make it fast by only using account and logon data from Orchestrator. But since you had changed something on Orchestrator already it comes to some mismatch :slight_smile:

2 Likes

@ui_xpath
you are always welcome :sunglasses: :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.