UiPath Advanced Training - Unable to see transaction items in queue

Hi All
When I run the dispatcher process, the transaction items are not getting loaded on to the queue in orchestrator. It is not visible in the “View Transaction” area either. I have tried most of the steps as per what I have seen from different forums online. Any help towards this would be appreciated please.

  1. Ensured that queue name is correct as per the config file.

  2. In process.xaml file, have tried using the if condition formula with “open” and also tried “0” at the end
    row(“Type”).Equals(“W14”) and row(“Status”).Equals(“open”)

  3. Have added the Item information for the “Add Queue Item” as well.

  4. Have reset the data on ACME and still no luck.

  5. Also have an error on studio stating “Detected unattended Robot as the license type. Based on the terms & conditions, this license should only be used for troubleshooting process”. Not sure if this is relevant to this issue.

  6. I also deleted the entire tenant and recreated a new tenant and ensured that my studio is connected to the orchestrator and is active.

  7. Under manage packages tried updating the versions of UiPath.System.Activities, UiPath.UIAutomation.Activities to v.21.6.1. (This was an attempt tried out of haste)

  8. Another change that I can think of which has happened is the orchestrator getting updated to the newer version as the options that I see in them are new.

PN:- When the project is run, it goes ahead without a single error and the output is generated with the correct transaction number as well.

Process.xaml (14.6 KB)

1 Like

Try adding log messages add relevant breakpoints, activate execution trail and run the project in debug mode.

Maybe you have a typo in Type or Status - it could be case sensitive and Open ist not equals open

Good luck

1 Like

Hi @vishnu.m2,

When no data is being added to the queue, it should not be able to process anything and provide you any txn number etc as nothing is there to process.

I got confused reading your steps and last point.

Could you please provide clarity on what is happening?


Whenever I run the dispatcher process, ideally the bot has to look through all the pages under the work items in ACME webpage and find out all the items with “W14” type and if it is in open status it has to extract that as a transaction item on to the orchestrator.

The bot is able to navigate through all the pages and extract the “W14” type without any issues. But this is not appearing the orchestrator as a transaction item under the queue. I have uploaded my process file for reference.

Hi @vishnu.m2,

After extracting ‘W14’ type details from ACME web page, have you added the same to the queue using Add queue item activity?

Was addition to the queue successful or it threw any error?


I did add it using the Add queue item activity. It does not throw any error at all. When I run the project, it completes without throwing a single error. But when you look in the orchestrator, the transaction items are not listed.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.