Uipath activity creator doesn't produce nuget

Hello All,

Been a while since I came here, yeah stuff happens, anyways I need help
So I was revisiting one of my custom activities, I thought it is about time to update it, but I when I try to publish it, it doesn’t output a nuget file and I get these files as results
I am using Visual Studio Community 2022 with latest version of UiPath extension

Kindly help
Cheers :upside_down_face:


Quick workaround:
Go to .Activities.Design file properties and check ‘Prodeuce a package file during build operations’:

After building/rebuilding go to .Activities.Design/bin/Debug and there should be generated nuget.
I hope someone will find better solution :slight_smile:


1 Like

@YAZIDI Welcome back to UiPath community

Before publishing package enable Include Sources Refer this post

Thanks for answer but we have problem with publishing nuget from Visual Studio, not from UiPath Studio

Thanks for the response,

I did try what you have suggested but UiPath studio didn’t accept it, showing the following error

The following package(s) can not be installed:
“[My Package Name]”

Try to rebuild only .Activities.Design project to generate nuget, not entire solution

I’ve tried both Design only and entire solution, same issue

Is there more informations about this error? This line doesn’t tell me anything :frowning:
Which version (v3 or v4) of activity creator are you using and what kind of project in UiPath you have (‘windows or windows-legacy’)?
This workaround works perfect in my case, maybe there is something wrong in source code

1 Like

I was using the latest so I supposed V4 with “windows”, but I did find a solution, a weird one but it works.
So what I did is first of all downgrade UiPath extension in Visual Studio 2022 from V4 to V3 (link here incase someone is interested → UiPath Activity Creator V3) then redid my project from the start, save everything then close, after that I open the project with Visual Studio 2019, build it and publish it form there, surprisingly it worked as intended

Really thanks for the help and support :+1:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.