UiPath Activation - Activation failed with error: -10000000

I am unable to activate UiPath Studio.

Dont know why Device ID is blank . Error generating Certificate : NSL Library not initialized.

Error description: NSL Library not initialized License status: Undetermined Device ID: Computer: xxxx User Name: xxxx

Can someone please help.

hi @Rajtk7

try to uninstall the uipath studio and try to install the uipath studio

Ashwin S

Hi Rajtk7,

you can try below mention steps .may be your problem will be resolve .

  1. try to delete all the files from uipath license folder if any file present there .

  2. then try to run below mention cmd

    cd C:\Program Files\UiPath\Studio\UiPath
    regutil activate /email=userEmailID /code=your License key

this will automatically activate your uipath studio.

Vijay Bharti

Check this as well if it helps,

Rammohan B.

This worked for me!

We are getting the same error, Our users devices are restricted and when the user opens UI Path they don’t get a Device ID generated. When I Open it (Admin access) It generates the Device ID. Does anyone know what it is querying on the device (Registry \ C Drive) to generate the Device ID?