UIpath 32BIT edition Installed when i tried to install community edition

Dear Sir,
Two things,
-I am new to RPA not I am not an ace developer.
-But I have seen couple of things , I have doubts about…

:> When I clicked on link of community edition to start learning RPA on my 64BIT computer, RPA installed 32 BIT version.
:>second , I was learning data type called ‘“DateTime” and practising it as per documentation’, however I got stuck at timespan and I am not able to substract the value of timespan and timtoday.
I created 3 variables and each assigned with system.datetime datatype , rest I am just following instructions given on webpage…please advise.

Third , yesterday when I start working on date time variable and craeted one empty sequence, tried some here and there things into it but unsuccesfull. So I shutdown the system completely and Uiclosed.
Today when I tried to open the XAMl file , variables got erased and everytime when I restore file and try to open , UI-studio FReezes up,
I tested it 3 or 4 times.
Steps

  1. Craeted new sequence.
  2. created variables.
  3. closed the system without closing Uipath individually.
    Result it does stored the file ut erased the variables and whenever I tried to open same XAML file, Ui studio freezes up.