UIElements - Quorum Land Onshore

uiautomation

#1

Scenario:

I am automating an windows application called QLS. I was able to identify the elements with selectors in the window panes a couple of days ago. But not any more, it is identifying the whole pane, instead of each element. What could have been the problem?


#2

Hi,
Looks like selector issue.
Please use UiExplore to get most reliable selector.


#3

Strange. Have you done any updates to QLS or UiPath?


#4

Client IT said, they refreshed their Database, which will drive all the data in QLS. But they did not do any updates for the QLS application itself.


#5

Strange. The UI layout might be in the database but this should not affect.
Have you tried on other computer/OS/UiPath version?


#6

Not yet. I will test it out on other computers and let you know. The tool is from https://www.qbsol.com/all-solutions/land-management. Do you think we need to look for settings, that will expose the UIElements.


#7

Is it Java? What UI Framework does it use? For Java apps you need to reinstall Java Bridge in case of a Java SE update.


#8

It is not a java application. It uses .Net framework.


#9

Let us know how it works on another machine.
Also make sure you are running both studio and QLO with same level access. Example: do not start QLO as admin if studio is not started as admin.


#10

Hi @priyatham,
Can you just do one small check and let us know?

  1. Open Notepad
  2. Try to identify the elements.
    Check whether you are able to identify the selectors on the same machine or not.
    Note: Especially identify the menu buttons.
    Regards,
    Jiban

#11

Hi Jiban,
I am able to identify those elements in Notepad.

Priyatham Kadali
Deloitte Consulting LLP
Tel/Direct: +1 407 417 1460
www.deloitte.com

PTO Alert : August 11th to September 8th


#12

Hi Jyoti,

We are using Virtual Desktop.
I am able to identify the elements in QLS as well as Notepad.
My Colleague is not able to identify the elements both in Notepad and QLS.

Do you think his machine is different from mine.


#13

I told you to check the notepad to ensure that you dont have a dll file issue (regsvr oleacc.dll issue).
In case of this dll issue you will not be able to specify the elements.

Try with admin privileges, you should be able to identify the elements,If you dont have the dll related issue.


#14

Hi Jyoti,
We both have the same privileges, but only one of us have this problem right now. Will this dll issue comes on and off? Can we resolve this issue?

When you say admin privileges, you mean the user who logs into the Virtual Desktop, should log in with adim credentials?


Selectors not working on Mac VM
#15

Hi @priyatham,
Admin Privileges: The current user should have admin rights.
But you should not face this kind of issues because of (not having admin rights).
Just give a try in case you want to fix the dll.
To fix dll related issues:


#16

Just FYI:

  1. when i change UiExplorer setting from “Default” to “UI Automation”, it is recognizing the elements once and then it fails.

Solution:
so the solution is to fix the dll issue.


#17

I am not sure about it, just try with that. I faced the same in my laptop but after fixing the dll it started working.
If it is dll related issue, you should not able to use the Open Browser activity to open Internet Explorer as well.
You should get the error: Can’t communicate to Internet Explorer.


#18

Thanks Jyoti, It worked like a charm.