UiElement not being found

Hi guys,

I’m making an automation where I hide the browser while the activity is running.

The task is very simple, the robot has to access a website and then it gets a value with the Get Text Activity.

However, when I run the application with the webdriver property selected and also the hidden checked, the bot does not find the element. I get this error message:

Get Text 'TD': Could not find the UI element corresponding to this selector:
<webctrl tag='TABLE'/>
<webctrl aria-label='Padrão' tableRow='1' tag='TD'/>

The selector is this one:

But, when I run the application showing the browser doing it, the bot finds the element.

I don’t know what’s going on. I’m using Chrome.

How could I solve it?

@Rodrigo_de_Bem

Use an activate activity…to get it to foreground again…

And I hope you have only one chrome window…because you are using star apart from that nothing

Cheers

@Anil_G

I did it, but it doesn’t work as well.

I think I’ll just do it with the browser being shown.

@Rodrigo_de_Bem

May I know what do you mean by hide the browser
Cheers

@Anil_G

I mean when the bot opens the browser and it does what it’s supposed to do, I don’t want this to be shown to the user. For example, the robot needs to access google and search for the temperature in its city. Then, I only want the value to be displayed in a message box.

@Rodrigo_de_Bem

Try using get attribute with chromium api checked or the webdrover checked…

Cheers

1 Like