uielement no longer valid in a dropdown

i have a dropdown wwhere i have to click a certain value according to my value which i got. when i use a click activity in that dropdown it is showing uielement no longer valid.( i tried attach window and get active window which is not giving me reasonable selector)
can anyone help me through this

@Jebarohith19 - which browser are you using? can you share a screenshot of the error?

im using chrome i solved this by using select item but i have another issue
i hae to click a checkbox but the checkbox is having idx only but not having “aaname” what should i do

look for a parent id or a class or any element which represent the selector in uniquely identifiable…

Parent id is there but it is different from the values i have

in here parent id changes but it is like subdivisions for tld parent id i haves tablerow=1,2,3 and for next parentid im having same tablerow=1,2,3,…

Good day,

I am having a similar issue with a dropdown in a desktop application. Did you resolve this? Thank you in advance.