UiDemo Login Performer Project: Password is entered in Username Field

I’m working on the UiDemo exercise in the Advanced Lesson Plan. Trying to login to the UiDemo application. When running the project, the username of admin is entered correctly in the Username field. The password is then also entered in the Username field even though I have a tab after the username. It then goes on to click on the Login button and of course returns the message Invalid Login. I have tried using Click Image which places the cursor in the Password field and it still enters the password into the Username field. Simple problem with a simple answer please and Thank you! Screenshot follows:

@Jrussell

Check ClickBeforeTyping option in properties of that Type Secure Text activity.

If you used Hot keys in Type Into field then check SendWindowMessage in properties instead of SimulateType.

Thank you for your response. When I check SendWindowMessage in properties instead of Simulate Type it does not type the username at all, types the password in the Username field, and then clicks on Login. I also checked the ClickBeforeTyping option in properties for both the Type Into and Type Secure Text activities. Please see screenshots:

image

@Jrussell,

Can you please try sending the “tab” separately by using send hot key activity and see if it works or not?

Thanks,
sid

Can you please post the selector you used for the type secure text password, and also post the selector you used for the type into username activities? I have a feeling you used the same selector for both :slight_smile:

can you insert Sent Hotkey after username and pass Tab to it .
And please remove tab which is there after username.

I am sure this will work…

Regards,
Ahtesham

Hi Dave!

Entering keystrokes along with text may not work sometimes and may take time to analyze and fix. Instead use Send hotkey activity b/n username and password activities.

I got the same result using the Send Hotkey activity.

Try re-indicating the type password activity again and please show the selector once you are done.

@Dave When I am selecting the Type Secure Text activity, you can see there is nothing in the Selector property. I couldn’t figure out what to do in this activity to tell it to use the Password field for the password. I thought the tab after the Type Into activity for the username would work. I tried Click Image and the cursor was in the Password field but it still typed the password in the Username field.

@Jrussell I think that’s the issue :slight_smile: - you should be providing a selector here otherwise it will not behave the way you want it to. You could also remove simulateType and also remove ClickBeforeTyping and it might solve the issue. Alternatively you could convert the securestring to a string and just put it all into the Type into username activity. However, in the real world you’d likely want to make sure you kept it as securetext and got the selector changed.

Can you show me what it looks like when you use UiExplorer and try to click on the password input box? How were you able to get the username input box selected?

1 Like

@Dave Well, that’s a good question. I just used the Attach Window activity and Type Into is the first activity under Do. I used a variable as input for the Username (used Asset in Orchestrator) and it types the username in the Username field. So when I’m selecting the Type Secure Text activity and clicking on Edit Selector, it doesn’t give me the option to open UI Explorer. I just used Indicate on Screen thinking it would then use that to know where to type the password.

We need to have selector,
FYI.
Below are my snippet where you can see there are selector for both the activity.


-Ahtesham

1 Like

Thank you. I’m wondering what I did wrong so that the selectors were not automatically generated.

@Jrussell Somehow i mange to find UiDemo.

Use the below file, maybe this will solve your purpose.
Main.xaml (9.6 KB) --Updated .xaml file

Step which you can follow to achieve this are:
Open UiPath Studio
Select Recording
Select Desktop Recording
Click on username - Provide username ( Remember to open uiDemo.exc in Background)
Please check Empty field and press Enter
Click on Password -Provide Password ( check both Empty Field and Password) and press Enter
Click on login
Press Esc
Save and Close

Hope this will hope you build workflow.

Regards,
Ahtesham

2 Likes

Thank you. It has at least helped me along the way. Even when recording, the selector for Username field indicates a password field but I am working around it and will keep working on it. Cheers!

1 Like

I got it to work by following @md.ahtesham steps, changing Type Into for password to Type Secure Text, adding the Send Hotkey activity between the username and password, using variables for username and password, and using Get Credential to make use of Asset in Orchestrator. Thanks to all for you assistance!

Performer.xaml (9.4 KB)

1 Like

Congrats @Jrussell

Please mark it as solution so that it could be helpful for others.

Cheers :slight_smile:

Ahtesham

1 Like

@Jrussell I think you are working on a window application , may I know why are you using a TAB as you have selectors to handle for type into??

@WhenCutEsh I was unable to get the password to type into the password field. It was typing into the username field until I added the TAB as advised above. I was unable to figure out how to do this using selector with the Type Secure Text activity.