UI web selector randomly works and doesn't work

I have a table of entities, each table row is a link to the detail page of the entity. Every detail page is the same.

My RPA is clicking each table row, opens a dropdown menu and clicks the download button that appears. So it downloads this file for each entity. This is what it should do.

However, it now is not clicking the download button about half the time. When I run it through the debugger, it highlights the element, and simply continues to the next step as if it has clicked, but it hasn’t downloaded. This randomly happens, definitely not always on the same rows. Some rows seem to have more issues than others, but always.

I have tried selecting simulate click, window messaging, deselecting both, changing the DelayBefore time, changing the offset (Even though with human clicking method it shows the cursor is exactly at the correct spot, it just doesn’t click). I’ve extensively compared the selectors of elements on different detail pages. I have changed the selector to the icon within the div, to have more indicators, everything I could think of.

I’m at a loss, is there anything I haven’t tried, or anyone who can help me figuring this out?

The element:

<a ng-href="/createinstance/4684888" id="btnDownload" href="/createinstance/4684888" uipath_custom_id="1">
                        <svg class="icon icon-embed2 " icon-name="embed2"><use ng-attr-xlink:href="{{ '/Content/svgdefs.svg?' + version + '#icon-' + iconName }}" xlink:href="/Content/svgdefs.svg?2.1.3.56456#icon-embed2"></use></svg>Download
                    </a>

My selector:

html app=‘chrome.exe’ title=‘PageTitle’ />
webctrl id=‘btnDownload’ tag=‘A’ />

Your selector looks fine so that shouldn’t be the problem.

Have you set the “WaitForReady” property to Complete? It may be clicking the element while it is there but not ready to function if that makes sense.

Our best practices are:

DelayBefore set to 1000
WaitForReady set to Complete
SimulateClick set to Yes

We rarely get selector issues with those settings


I have the settings just like the best practices, except that I have fiddled with the delaybefore, it is currently set to 3000.
See image for all settings

Try clearing the Offsets and reset the position to “Center” and see if that makes the difference

The 3000 delay before you have will be fine, just gives the element a bit longer to get ready

This didn’t help. Also, when I had window message and simulate click unchecked, the RPA moved the cursor to the field and was directly in the center. It just didn’t actually click the element. Instead it just moved on.

I’m using this in Chrome btw, so it’s simply a website. It is confidential though, so I’m not allowed to show any details of the website.

I’m at a loss then sadly. Can you try it in IE to see if that makes any difference?

IE: After about 30 seconds it’s finding the buttons, but it’s taking really long. I will check how it works out as in if it can find the button on each detail page.

IE is very very slow, not even erroring after 30 seconds of not finding the object. I will try to use IE tomorrow.

I have tried in IE now. IE had a lot more trouble finding any elements in the website, as I said it took over 30 seconds for each click. Clicking on the row in the table, clicking to open the dropdown and clicking to start the download.
It failed on the download button quite often. It couldn’t find the element, and threw an error. This is much different from Chrome, where it found the element but just didn’t click.

I also tried getting a director off of the top 25 movies in a list on IMDB, this was normal speed I think.

However, the speed is not the issue, as Chrome has worked fast enough. The issue is that it doesn’t click the element after finding it. I have run the program to go over thousands of table rows before, and it downloaded every item then. My program didn’t change anything in between, but it did stop working.

what site is it? Is it an internal web app?

It’s indeed an internal webpage with confidential data, so I can’t show much at all.