UI Studio throwing errors when trying to invoke a workflow with selectors

When trying to invoke a workflow that has selectors into my own main xaml, I am getting this error *04/29/2022 15:35:50 Invoke Workflow File:
‘DynamicActivity’: The private implementation of activity ‘1: DynamicActivity’ has the following validation error: This activity is attached to ‘a9a6b59b-a25b-4907-8874-767d5166ad54’, but no card with gi The exception message has been truncated due to size. Use ActivityValidationServices to see all violations. ",

I don’t really know what it’s about but I’m sure I setup the invoke workflow activity correctly and the other workflow works fine when ran independently.

Help is greatly appreciated :slight_smile:

1 Like

Hey @adeneke

Are you using UI-Object Repo ?

Thanks
#nK

Hello @adeneke

Can you share a screenshot of the .xaml files and the import argument list? Also in the automation are you using any custom activities?

Also is there a provision to run both xaml independently and to check whether both are working or not. If works idnependently then some parameters are invalid in the invoke workflow activity.

No. I didn’t use the object repository just modern ui activities

I am not using custom activities, and yes I ran both xamls and they work fine independently but now I am trying to combine them under a for-each row loop, I am using a Data-Table and the current row as arguments.



In the second flow can you add a message box and print arg_in_CurrentRow(0).ToString. Also in the first xaml print var_CurrentRow(0).ToString

yeah, first one works fine but the invoked one doesn’t go through

Failed or passed???if failed an you share the error screenshot

It’s the same error as the one I posted above

This happens when you move an activity from inside a scoped activity (ie Use Application/Browser, Attach Browser, Attach Window, etc) and put it somewhere that’s not inside a scoped activity.

Putting the Invoke Workflow inside the scoped activity doesn’t work. The scope doesn’t follow down into the invoked workflow’s activities. You’ll have to add the scoped activity INSIDE the invoked workflow.

Open the invoked workflow and click the Analyze File (not Analyze Project) button.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.