UI Selector on RDP selects the whole browser UI instead of the specific button

Hi, so I was automating a process where in it navigates in a certain web browser and does a bunch of click activities.

So everything works fine whenever I run it in my actual desktop, but when I run it in my RDP session, it won’t find the specific UI selector for the Click activity (in this case it just has to click on a specific text named “More…” - check image below), I tried to debug it in the RDP session but every time I use a click activity or anything that has to do with UI selectors (Click, Click Text, Click Image, Click OCR Text) it prompts an error saying that it can’t find the certain UI selector - mainly because it won’t find the specific button and just chooses the whole browser (a little different error when I tried to use Click Text, it says “The method or operation is not implemented”)

image

The process goes like:

  1. Login to website
  2. Navigate and do a bunch of click activities

It stops at the second step.
Could this UI selector problem in RDP possibly be a bug in UiPath? Can you guys help me with this?

P.S. I tried to debug it in my actual desktop, copied the selector generated and pasted it on my UiPath in RDP, I also tried using the recorder but it tries to click the whole browser whenever I hover on the “More…” button, none of them worked.

Regards,
Mc

1 Like

Hi @UiP_Mc,
On remote machine you need to have runtime installed:

On machine with studio you need to have RDP Extensiona installed:

With this all should work fine :slight_smile:

2 Likes

Hi @Pablito, should I install both? I have UiPath installed in my RDP.

Also, what’s the difference with Java Bridge and Chrome Extension?

You need to install runtime on remote computer side so it will be able to contact with RDP Extension installed on your computer in term of UiElement etc. Without it no selector will be visible in Studio when working with RDP machine.

So what you mean is that I should have this runtime installed in my actual desktop and not in the RDP? Will this make fix my UI selector problems whenever I debug inside RDP? Please do correct me if I understood it differently.

Regards.

Please read carefully:
Runtime = RDP Machine
Extension = Your machine

Oh ok got that, I just got confused with the terminologies used. I’ll inform you once I finish installing it. Thanks!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.