Ui Robot fails after 45 minutes

Hi all , I run my Bot and minimize window but whenever I do so my Bot fails after 45 minutes exact . I have almost 100 transactions in my source excel but out of 100 it performs 36. The same when I run in interactive session works. I have increased my systems Sleep time as well but that doesn’t help. What could be the issue any idea? I am using 2019.7.0 vStudio

Thanks!!

1 Like

Good morning Shailesh, are you able to provide general details about what the bot is doing?

Is it only processing Excel data?
Does it work with websites?

Hey @chenderson chenderson - Yes its using Excel as a source data and operating within a web application to scrape a datatable. So it involves scraping data, saving it to the excel and updating the source excel with a comment . But each time when I run it , it fails at the 36th Transaction . I’ve used Maximise window as of now and re run the Bot not sure if it will work. Any sort of input will be appreciated . Thanks in advance.

For any activities that interact with the browser, what is the setting for the WaitForReady input?

If they’re set to “Interactive” or “Complete”, set them to “None” and try the process again.

This was an issue in the training exercises as well and the only solution I found that worked for me.

@Shailesh123

Check your Orchestrator may you seted Stop After time

Schedule -> Action-> stop Jog after see below screenshots

Make sure it this Null

1 Like

@amaresan I am not scheduling my Bot as of now . So I haven’t used that property.

Hi @Shailesh123,

I’m eager to know the logs in the output panel.
Can you just post a screenshot here?

1 Like

@Shailesh123
Then it throws any error?
If not check while or for each condition…if you used for each row activity then check datable count in Uipath…

Otherwise share the xaml we will check & let you know…

Thanks.