Ui Explorer giving invalid selector

Using the UiExplorer, I’ve selected a text box. This generates a selector which I can highlight, but as soon as I click validate the selector becomes invalid and can no longer be highlighted.

Selector looks like

<wnd app='jplauncher.exe' cls='SunAwtFrame' title='Oracle Applications' />
<java name='Transactions *' role='internal frame' />
<java name='Date Requested' role='text' />

This is invalid. When I omit the name ‘Date Requested’ it becomes valid but highlights the wrong box.

I’ve tried using ‘Find Children’ with the filter “java role=‘text’” and changed the option to ‘Find Descendants’, but this doesn’t find the text box, even though the UiExplorer shows the text box as existing beneath the element I’m searching.

Any ideas?

1 Like

Hi, I am having the same issue with all the fields. Any help is appreciated.

1 Like

Any solution guys?? This is frustrating

Hi there,

Not very sure about java apps, but from your selector I am guessing its an iFrame?

if so do you get any ‘src’ source attribute? If so then launch it in a different window and you can carry out your activity.

Or, have you tried looping through all elements through ‘Find children’ and keeping a conditional statement that looks for the name attribute as ‘Date Requested’ and as soon as it encounters that UiElement the text is written using either set text or type into.

Try this, hope this helps.


Is installed the Java Extension in the Machine?