UI Activities are not consistent while automating a tool called "Aggresso"

Hi Team ,

We are trying to automate the process steps which is done manually in the tool Aggresso. UiExplorer can identify some of the elements in the tool , but when we use UiActivities to automate process steps , it is inconsistent . For example, Type into Activity for entering an ID into an identified text field is not working . Like wise when we use Click Activity to Click an Element under Menu Item is not working Consistently.
There is an process step to manipulate an worksheet which is pulled from the tool by an click event. The worksheet is identifiable but the elements inside the worksheet are not. We are facing difficulties in automating the process steps in the tool , Please provide us guidance to handle the issues ASAP.

Note : We have tried recording the process steps in Citrix automation. It is not working consistently.
Please find the attached screenshots of the tools. Highlighted are the element has to be processed by Ui Activities.

Thanks and Regards,
Yogapriya S

ScreenShots.zip (326.1 KB)

What’s the order that these steps need to be executed?
And which of the highlighted elements are problematic?

Is this the Unit4 Agresso program? I did an automation in Agresso - and in my experience playing with the activate button on click/type into seemed to work with my issues (I also had som issues where it sometimes would click and sometimes wouldn’t.)

Also - Agresso has hotkeys for almost anything, and they seemed to be much more efficient.



Hi Cosin.
The highlighted are the elements which were problematic to automate using UiActivities.
We tried using Send hot keys, It is working now.
Thanks for your reply.

Yes , We are proceeding the automation with shortcut key combinations. Thanks for suggestion.It helped us a lot.

I am having the same issues. Especially when I try to select a cell in a sheet, like in the picture you uploaded called “Sheet1”. The click activity only marks the entire sheet and not the cell, so I have tried to use various other functions without success. If I was to use hotkeys, then “tab” would kind of work, but it would be time consuming “tab”'ing through the worksheet cells. Any tips on how to click a cell in a worksheet when the UiPath only recognizes the sheet and not the cells?