Type into - unpredictible behaviour


#1

Hello,

I am trying to make a robot that inserts data in a terminal with specific fields. Because I was not able to establish a connection with the terminal through Terminal Session activity I decided to use type into activities in a container with the terminal application.

Based on the data received as input I made several rules for combining the typing with sending the tab key. I even tested it for various situations and worked just fine but suddenly it all started to do unexpected things. For example, it once started to type characters such as @#%#^# instead of the string values from variables. After that (using the same input data) at one point while typing it got back and overwrite the previous field (and when I tested again for same data it did it again but for a different field). I don’t set any target for type into activities because I basically work with a black screen so I just want the information to be typed in the order I set.

So my question is: do you have any idea why would Type Into activity act like this? (I also tried to check/uncheck the Activate option)

Thank you!

Studio/Robot/Orchestrator Version: Studio Pro 2016.2.6274

OS Version: Microsoft Windows 7 64-bit