"Type Into" sends wrong symbol instead of comma in command line window

Hi guys,

While implementing the following task: open cmd → attach window (“Type Into” cmd window text: (A+B).ToString + “,” → close the application.
A and B are of type UiPath.Core.GenericValue.

I’ve got the following output in command line: 579?
Later I have tried this expression : (A+B).ToString +Chr(44) , and got the same result.
However when try this (A+B).ToString +Chr(43) , I’ve got proper ASCII character: 579+

Please help to explain this.

Regards, Dmytro.

What do you need to be typed?

579,

can you show the workflow

Hi @Dmytro_Stoliar
type tjhe value as (A+B).ToString"+"Chr(44)

Thanks
Ashwin S

It produces compile error : “End of expression expected”

Small correction there buddy . Its (A+B).ToString+Chr(44) @Dmytro_Stoliar use this

Hi @vishal.kp
Correct vishal type error :slight_smile:

Thanks
Ashwin S

1 Like

This is the outcome: 579Chr(44)

(A+B).ToString+Chr(44) @Dmytro_Stoliar

579?

your not getting “579,”?

Nope.

Capture
i am getting it correct

Strange, I got this every time:
image
Do you have by chance any guess to why that happens?

send me you workflow file @Dmytro_Stoliar

Unfortunately , I can’t send attachments anymore, it says the new user doesn’t have rights to do it.

message me the attachment by clicking my profile. Under it there is messaging option @Dmytro_Stoliar

Sorry ,the option is absent for me .