Type into or any other alternate activities don't work for text box

I am using Community Edition of Uipath. I am trying to enter text into the text box of a web application.The selector is not standard and has only id, idx, row, column values. It doesn’t give exact row column values as well. I see something else. Tried Anchor Base Activity. I have tried Type Into activity with various options default, send windows, simulate, click before typing, activate, wait for ready, Set Text Activity, Hot keys. Nothing worked.

There are few text boxes in the page. It works for few text boxes. Doesn’t work for few of them. Please suggest how to resolve this.

Thank you
Surya

Hey @SuryaAngara,

Welcome :slight_smile:
You seem to have studied the selector correctly
In that case, use image recognition to navigate, even though it’s less likely to work in the long term, it will probably work. (just like in a citrix environment)
If you need more help to debug a selector, you can give us an example.

Hope it helps :hugs:

1 Like

Hi
welcome to uipath community
we can try with SEND HOT KEY activity where use key as tab and it would navigate through each field for each tab key used and then we can use a simple TYPE INTO activity without any selector chosen with the input string to be typed
–so the sequence be like this
SEND HOT KEY with key tab
Type into activity with input string + "[k(enter)]"
again SEND HOT KEY activity with key tab to navigate to the next text box
Type into activity with input string + "[k(enter)]"

so this would type the text into the text box for sure
and also make sure that the property SENDWINDOWMESSAGE in type into activity is enabled and SIMULATE CLICK property is disabled as we have use [k(enter)] along the input

kindly try this and let know for any queries or clarification
Cheers @SuryaAngara

2 Likes