Type into not working in background on file explorer pop window

I need to upload files to a website for that I have to type into the file name in the pop up box using Simulate type feature but this is not working.

Have you tried click before typing property

Thanks
Ashwin.S

Yes, I have tried ClickBeforeTyping property but I want to make it run in the background. When I choose SimuateType property it doesn’t work.

Hi @farhi!

Did you tried with send hotkey?

Cheers!

Hi @farhi

Could you also try with the SendWindowsMessage option? It will also work in the background, but might be more reliable than Simulate Click in some cases.

1 Like

Hi,
try to include Attach window and make selectors dynamic, inside the attach window use hot key and type into to write the data

I tried with SendWindowsMessage property but no luck!

Can you please send me a sample xaml? I tried with Attach window but Hotkey selector is not working.
Thanks!

send me the url or any screen shot ?

Sorry I can’t send you the url.

Hi

–use attach window activity and select that popup as element while selecting element for the attach window actiivty
–use a click activity and click on that popup (while selecting the element) and enable simulate click property
–now use a type into activity with the field where we are going to type, selected as element, with these properties enable like clickbeforetyping, emptyfield, simulatetype property…and waitforready property as complete

hope this would help you
Kindly try this and let know for any queries or clarification

Cheers @farhi

Hi @Palaniyappan,

I’ve tried that, but it still not working.

If I set SimulateType=True then nothing happens, the popup window doesn’t react.
If I set SimulateType=False then it works fine.

UI Path Studio 2019.7.0 Community Edition
IE Version: 11.239.18362.0 Update Version: 11.0.135 (KB4507434)
Microsoft Windows 10 Pro Version 10.0.18362 Build 18362

Can anyone help?
Cheers

Hi @AlexGorbunov,
Its 11months now, sorry to bump this topic…
any update on this issue, were you able to solve this?
Anyone, who could help?