Type Into issue when type number with decimal point in Chrome

I am using UiPath to maintain data in a webpage via Chrome.

The Selector is “<webctrl id=‘input_forecast_2021_2_0’ tag=‘INPUT’ type=‘number’ />” which I understand only number can be typed in.

My input value is 12.5 and I use Type Into activity to key in. The data type should be string in Type Into. So I write “12.5”.

But when the robot run finish, the value in webpage is 5. Just keep the number after decimal point. If I write “12.55”, the result is 55.

I assume the issue is because of type=number in selector which is conflict with data type in Type into. Am I right?

Is there any solution to fix it?

Hi @zhengyao - I just tried the below in my workflow and it worked in chrome…



Hi @zhengyao
Welcome to the UiPath Community!

First of all, about your last point of datatype mismatch - anything you type into a web browser is technically ‘TEXT’ so ‘Type Into’ should work 100% with any field on a browser.

The input type ‘number’ just comes pre-built with validations to reject non-numerical entries.

These are a few things I would like to point out/recommend:

  1. Try if you can manually type 12.5 in the field. As an example, if the validation dictates that text should be cleared as soon as users presses any non-numeric character (including dot . ) then you may not see that happening on screen because robot types too fast.
  2. Another could be that the robot starts to type as soon as the page loads, without waiting for the particular textfield to load. Set your ‘WaitForReady’ = COMPLETE property in ‘Type Into’ activity.

Hi @zhengyao - Can you please let me know if you were able to find a solution to this issue. Am also facing same problem. The deciaml value is not being typed into prperly.

Any help is appreciated.
Thank you,

Hi @srividyakittu
Welcome back to UiPath Forums.

Have you tried the solutions suggested above? Are you able to manually enter the value in browser?

Hi @RPAForEveryone,
Sorry for the delay in reply. I tried the solutions suggested above, but with no succes. I am able to type in manually on the text box in the website.
I have found a way to make it work. I have used type into activity and and passing the value as (input_double_value).ToString. Also as suggested, i have made WaitForReady as complete and unchecked SimulateType. This seems to be working as of now.
Thanks for the help.