Type into is not working well


I have a problem with type into activity.


  1. Open excel
  2. Using hot key alt+f8 to open macro selection
  3. Using type into, enter the macro name ( macro name is variable which I get from another file)
  4. Click run


  1. The type into write the variable name BUT with addtional string infront.
  2. In this case, it supposed to write A_データシートの初期化, but the output become $E$7:$AZ$470A_データシートの初期化

What I have done

  1. Check the output using message box.
    The result is okay and the output is A_データシートの初期化 but when using the type into still have the additional string infront

  2. Activate the click before typing, Emptyfield and sendwindowsmessage but still have the additional string infront

  3. Used execute macro and the macro executed but my robot stuck( not even throwing any error) and not continuing to next activity.

Please let me know if you have the solution for above.

Hi @hairulazizan ,

I would replace all the search related actions with an Invoke VBA activity (https://docs.uipath.com/activities/docs/invoke-vba)

Best regards,

Hi Marius_Puscasu,

Thanks for your reply. It is nice to do with Invoke VBA but yesterday I have found another way. Instead of typing, I just use click and send the variable into selector and it worked.

Great !
Don’t forget to close your topic by marking it as solved so that we can filter unsolved issues :wink:

Happy automation !

Hi Hiba_BHiba Beldi,

Sure. Thanks for the reminder.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.