Type Into is not typing the correct capitalization into html textbox

I am not getting any errors but when I use type into its not keeping the same capitalization or punctuation as the variable has.

It is a fairly long string but there is no pattern to where it messes it, it just seems random.

I’ve been reading on the forums to add a delay between keys which has helped but not solved the problem.

An examples of whats happening.

     Variable value                        :                What is typed

REFRESH by drinking Cold water : REfRESH by drinking cold water

My settings for the type into can be found in the picture attached
rpa

@wstarke17

Could you please uncheck SendWindowMessage option and check ClickBeforeTyping and SimulateType option and then give it a try once.

Hey @lakshman,

Just tested, with the SimulateType checked it doesn’t type anything strangely and without the SendWindowMessage it will sometimes lose formatting of the paragraph.

@wstarke17

If you are sending any hot keys along with the text then you have to check SendWindowMessage option.

As of now uncheck SendWindowMessage and SimulateType options and give it a try once.

@lakshman

Nothing that I would consider hot keys, but I am new to UiPath so I may be mistaken by that.
This is one of the values that is being passed in

“When its hot out\n\nREFRESH by drinking Cold water”

With neither checked its typing it as is without the return keys so
“When its hot outREFRESH by drinking Cold water”.

With SendWindowMessage checked it will type with the return keys but messes up capitalization in random places.

With simulate just doesnt type.

Thank you for all the ideas by the way!

@wstarke17

I guess you are using \n for newLine right ?

If yes then try this once: “When its hot out"+vbcrlf+""+vbcrlf+"REFRESH by drinking Cold water”

And I chekced from my end its working fine. Please find the screenshot of my Type Into activity properties.

2 Likes

That worked! Thank you so much!

1 Like

@wstarke17

Could you please closde this thread by marking above my post as solution.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.