Type Into 'INPUT': Column 'Last Name' does not belong to table DataTable

contacts.xlsx (8.7 KB)

Hi Experts,

i am working on the google forms fill in details from excel spreadsheet.
when i run through the project, i am receiving the error as “Type Into ‘INPUT’: Column ‘Last Name’ does not belong to table DataTable”

i tried using index number but still no success.

Please help me i have attached the xlsx file and xaml files for your reference.

Google excel demo.xaml (16.8 KB)

Thanks in advance.

Regards,
Girish V

I assume that you’re trying to reference a column name that isn’t in the datatable created from your workbook. Can you share a ZIP file with your whole project? When I load Main.xaml, there are dependency errors which prevent me from running the workflow.

Google excel demo.zip (26.8 KB)

Please see attached.

Thanks so much!

When you’re reading the datatable, you’re only reading A1:A2, which is the first first name in the workbook. If you want all of the data from the first row only, use A1:D2. If you just want all of the data, delete the A1:A2 reference from the Read Range activity. This will default the Read Range activity to reading your entire workbook where data exists.

Excellent! Its working fine,

Good catch :slight_smile: