Type into & Hot Key Activities not working in Background


I am running a bot using REMOTE CONNECTION. The BOT performs all the steps as UI actions. The issue is that when my machine is locked, (NOT THE REMOTE CONNECTION), actions like click is performed but Type into and Send Hotkeys activities fail. The error message is “Desktop has been disconnected while performing UI Actions”.

I have checked the Simulate key property and the activate property as well but to no avail. Also, the activities are placed inside the Excel application scope.

I am using UiPath Studio: 2018.4.4

Any idea how to run the process in such a scenario? The Remote connection window is not minimized. Also the process runs long for 2-3 hours which makes the physical machine locked out.

Hi @pearlb ,

Please set SendWindowMessages to True and try.

Please mark this as solution if issue is resolved.



i have tried with SendWindowsMessage as well. it still doesn’t work.

1 Like

Hi @pearlb,

Is the VM instaled in you machine ?

If yes its explained you VM is reading your machine.

Usualy in my computers are in a loked room and i just left a little video in media player runing in loop so the machine dont go to sleep becouse of the company policys, so the computer wil never be loked and hi dont have that kind of problems.

That just some idea, but youmust make sure the machines will be in a safe room, becouse VMs in your machine will be always like that.

Did you get any solution for this?, I have the same problem with Type into activities in excel scope running in background

I also face same issue background hot key not working .