Type into goes into the wrong field

Hi, I’m trying to automate a process to automatically search service requests in a list. it looks through a large number of service requests. For some reason the first iteration will correctly type the service request into the correct field, but in the next iteration it would go into the next field or it won’t find the field at all. I have no idea why. I tried checking the selector can’t seem to fix this random issue.
selector
image

Hi @J_Z,
Try with Anchor base activity


In Find element activity indicate the label of that Text box
And try with type into activity
Regards

I have a bit of the same problem. And UIPath even highlights the right spot when you ask it.

I need to type into field A but it ends in field B, and if I use anchor base, it ends in field C. The problem started after I upgraded to newer java version, and even though I reversed to the older, it still there.

Was working with the old before the upgrade.

I have no clue why.

kind regards
Per

idx is not a reliable selector. It keeps changing. Please try to choose a different attribute like aaname, id.

Thanks, will try, Just funny that the hightlight feature hits the right spot every time.

kind regards
Per

thought I found the right thing.

there is a virtualname calle VTextField121 that should be the right spot, and it highligts when I use the highlight function. But again, it jumps to the next field, as if tab key was hit.

If I change it to VTextField122 it highlights in field B but types in field C, if I do VTextField122 it highlights field C and type in field D.

AHA I thought, somehow it adds 1, so I just did a VTextField120 but that does not validate, so the field is nonexistent. :frowning:

No clue what to do now, Especially since it worked fine before. (forgot to mention, its a jave form based application working up against an oracle database, so the fields should change much.

Kind regards
Per

Try to replace VTextField121 as VTextField*

Thanks Rahul, will try. Reinstalling java atm.

Kinds regards
Per

Hi again, was worth a try, but will not validate.

I noticed that the 121 now is 4 when I go into the editor, idx still 3 if I dont remove it.

Kind regards
Per

Well tried to just type a string in the variable field of the type into, and BEHOLD it worked.

So it looks like its the csv file I read the variables from that have a corrupt entry where they have a hidden tabulator in front of the variable I read.

Sorry for the inconvinience.

kind regards
Per