Type Into Error Field

Hi All,

I have tried all possible selectors for the below field ‘Type Into’ a field but in run time it throws error. When I higlight it points correctly but at run time it throws error. I need to enter values at ‘RATE’ field and this value varies ar run time.



Have you tried switching from default to Hardware or Simulate?

Is this a windows app you are working on?

Hi @dutta.marina

Did you try using an Anchor for Rate keyword above the input field, also can you try to fine Tune the selector.
It might be the case that due to selector issues it’s not able to identify.


Show us your selector.


I have used Anchor here




Its a window application

That’s not your selector.


Can u help in this case. What should I take?


Have you tried other frameworks for identifying like UiAutomation, Active Accessibility, maybe those can give you some stable properties.

Hi Praeet,

I am not very sure Active Accessibility. Can u let me know

Show us your selector. It looks like this:

"<webctrl tag='INPUT' type='text' />"



is your TableRow=2 correct, try making it =1 and see what is it indicating.
anchor should have something as aaname or colName=“Rate”

Do you have a Click activity that’s clicking it before the Type Into activity? The selector may change after it’s clicked. Also that selector isn’t very specific. Is there an aaname or some other property that tells the specific name of the field?