"Type into" does not complete the typing


I’m trying to enter a path into Navision by using Type Into activity and sometimes ( 60 % ) does not enter the full string and it execute the next commands which will throw an error since the path is not correct.
The process is described below:

-Type into: in_path ( argument )
-Do While (check=false):
getText : Store actual entered text into variable ‘actualPath’
check if actualPath is equal to in_Path, if not, loop, if yes, exit from loop and proceed
with the next steps.
The goal of this modules is to wait till the whole string ( in_path) is entered into the search box and only after press Enter.

Hi Alessio,

you can try to accomplish this in different ways:

  • Before the assign False you can put a wait in order to let the page complete the insertion, also it will be better to put a maximum number of tries in order to avoid infinite loop that can occur;
  • You can try to use the send Key instead of the Type Into, or use the Hardware mode for Type Into if still not used, sometimes this is more effective;
  • Moreover you can try to store the path into the clipboard and paste it inside the field, this should copy all the path instantly.

If none of this works, can you share the Properties of the Type Into Activity in order to better understand the issue?



To debug this issue use the delay activity giving 15 second delay before the do while condition and see what is happening? is this writing whole text or not.


Hi @alessio.giovannini

Did u use simulate type into there ?

Hi All,

I tested all your solutions and first of all, thank you for your help and all the different options you proposed, unfortunately the problem looks to be something else. Why Am I saying that?
The single sequence, if executed with Navision open, it works every time while when it’s executed after the first sequence used for the login : Start Process - Click - Click, it fail without writing anything.
Do you have any idea of what the problem can be?

Hi @alessio.giovannini - Did you made sure you are typing into the write place? because lot of time when you click the address bar in the file explorer it will not work, since i already tried that method. So I clicked the drop down at the end of the address bar and then typed the path. Please check this post…

When you are using Type into. remember that the robot is typing like the human is typing. Hence, if you are typing a capital letter like “T”. The robot is actually typing “Shift”+“t”.

If the robot is not able to complete the text when typing. This maybe due to there are shortcut commands in Navision that the robot is clicking. I suggest you click on Simulate type. Or use Set text activity if possible.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.