Type Into, DataTable/Excel - jumping around in target application


I have a strange problem when trying to enter data into a target field of an application. Due to various reasons, please believe me when I tell you, the target applications name does not matter: it’s for sure not a “standard” application.

  1. Read Excel
  2. For each row (Datatable)
  3. Type into field row(7).ToString, SimulateType
  4. Commit via “Do”-Button

If I check, the target field is always empty after the commit. An interesting fact is: it does write the full excel table (with quite some text) in “one” step (you can’t see it typing…).
If I remove the “SimulateType”, it’s typing until the first “cr,lf” and then jumping around in the target application. It’s much slower as well (of course), so I would like to use “SimulateType” if possible.

Did you face the same problems? What did you do against it? I had a separate “Type Into” with some “Dummy text” (I can filter out afterwards, it does not matter for the sake of it) without “SimulateType”. After that, it usually stored data in the dev environment (this was reliable). But in the “test” environment, it’s not anymore.

Any suggestion?
How do you filter “cr” and “lf” from an excel input? tried replace(vbCrLf, “”) and similar - it does not seem to capture it at all…
You can safely assume that the application is fully loaded and ready to take any input (in fact, I also worked with static delaysbefore, delaysbetweenkeys, etc.).

Your help is really appreciated.


Is the data coming properly from Excel file or not and try to display those values.

Sometimes already data will be there before entering some text into Text box. Here, you are using Type Into activity and check both activate before typing and Empty field in property and give it a try.


thank you for your response. The data is clean, just “cr,lf” at the end of each line. The workaround is to have a “type into” with “SimulateType” not active after the main “type into” with SimulateType active. I therefore are able to save the data as required. This is weird, I know…