Type in issue on a search field


unfortunately theres one phenomenon when running my code, independent of the browser. In the past it worked quite good, but now i cant search for order numbers in a search field on a website any longer, where orders are listed below. I made an anchor with a type action to fill this field. I can do what i want, but the bot everytime searches for the same specific number only, and no other numbers are possible. The same code hadnt probs till today and was searching for any number which were a parameter in the type action. It carries out all steps but only with that specific order in a loop (in which i covered the code). If i delete the related order, the bot doesnt do anything. I tried to make a new project with only the initial steps again, restarted UiPath and reinstalled the browser plug-in, but that didnt help. I dont` t think that there has been made any changes on the website.

It seems as the bot makes a click on the small menu, instead of typing into the search field. I tried to indicate an anchor/Element again, but without any effect. Does anyone has an advice?


Don`t know if it helps to look into the code, but here is a new process with only the initial activities:

Main.xaml (7.7 KB)