Twilio selectors not playing nice with hotkey and standard/CV click activities

Good morning,

I’ve been tasked with automating the porting of phone numbers into Twilio. Before I go any further, this is something I’ve been able to do before but on this second go-around, things aren’t looking so good.

My main issue is with the dropdown menu selectors, or at least what Twilio calls a dropdown menu. After trying with the below activities, none of them recognize the “Configure with” dropdown and won’t establish the selector I would have liked to have

  • Select Item
  • Select Menu Item
  • CV Dropdown Select (this one will find the selector, but not grab the list item)

Now I already knew this, so my fix was to program the bot to manually tab through the Twilio page and use send hotkey activities to get the right option from the dropdown menus. It worked, but now it won’t. To my knowledge, the Twilio page I’m interacting with is the same one as when I did this for the first time, but the selectors are all showing as invalid. So, I essentially had to start from scratch. I tried to mirror what worked the first time and that just ended up with the bot tabbing all the way to the “Configure with” dropdown, but my “down” keys didn’t work as intended. It’s like the bot is sending the down keys as if it’s “entering” that selector for the first time, and not cycling through whatever options are available.

After trying and retrying everything I could think of to make the tabbing down to the dropdown work, I realized that the Click activity might provide some resolution. I set up the bot to tab down to the “configure with” dropdown, click it (shows the options, and then click the highlighted SIP Trunk option, but the second click would not register even though the element had become visible on the previous click.

I’m about as annoyed as I’m allowed to be with this and now I’m at that point where I need some additional opinions. Is there any way for me to more accurately tab through Twilio or configure my click activities differently to get the desired outcome?

Before you suggest it, I did look into some Twilio integration packages but those were only good for phone call automation, not porting into the Twilio console.

Hello @Kyle_Shahenian!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

Hi,from my experience using tab should work on most aplications ,
have you try to use the click image? then use hot keys ?

Not sure what image you want me to click and tabbing had worked out for me in the past as well with this but after tweaking the selectors a smidge (because they all showed up as invalid) the tabbing/down keys won’t register the way I want them too.

I even tried clicking on the drop-down menu to reveal the selectors I’m trying to tab to, but when the next click activity runs it goes away and doesn’t get selected. In a way, I’m trying to create a manual “Select Item” process by clicking once to open the menu and again to select my item but that isn’t working.