Tutorial on UiPath Chatbot Connector

Hi All,

Along with the public preview release of the UiPath Chatbot Connector feature, I have published a technical document on UiPath chatbot connector along with a step by step video tutorial that describes how to create a simple chatbot and connect it with the processes published in the UiPath Orchestrator.

You can find the document and the video down here along with a link to my Linkedin post.

LinkedIn Post
https://www.linkedin.com/posts/lahiru-fernando-6262a429_next-generation-automation-with-chat-bots-activity-6658944410652418049-7E2G

Second issue of Era of Automation - Next Generation Automation with Chatbots
Next Generation Automation with Chatbots.pdf (564.8 KB)

Video tutorial link

20 Likes

new Demo with Covid 19

5 Likes

Hi @Lahiru.Fernando. Thanks for the explanation. I am facing an issue here. I am not able to connect to Dialogflow even after private key is provided. The CONNECT button is greyed
out.

1 Like

Hi @amithvs

have you provided the exact same Product ID, and the service account properly?

When copying the private key you must make sure you copy the value starting from the first doule quotation to the last double quotation excluding the first and the last double quotations… Just make sure you have no additional spaces at the end of the private key or at the begining because it can cause the Connect button to gray out…

Copy and paste it again to see whether it works…

1 Like

Hi @Lahiru.Fernando.
Great Video.
I am facing a little issue though. I have followed all the steps but it doesnot seems to work for me.
I get an error as below:

.
Could you please let me know what am i doing wrong?
Thanks in advance

HI @ashishsinha1504

Thanks for the comments :slight_smile:

Can I see a screenshot of the Actions and Parameters section of the Intent of Dialog Flow where you joined the process?

@ashishsinha1504

Even I had encountered this error while trying out the chatbot.
The error was being thrown due to the different variable type for the same parameter in Dialogflow and UiPath.
If you have defined sys.date/sys.date-time as the entity in Dialogflow, just check if you have also used the Argument type as DateTime in the UiPath workflow.

Please check and update if this works :slight_smile:

1 Like

image
Here it is. Also one weird thing when i am logging out of uipath,chatbot.com the existing connections are getting deleted and I have to create new. Why is that happening

The try section in the dialogflow is woring fine.
image

The parameter section seems to be fine. Now Can you go to the Map page of chatbot connector, and get to edit window of the joined process and show me how the parameters are mapped between Dialog Flow and the Process arguments?

Also show me a screenshot of the arguments panel of the process…

– This works fine because at this point, it only runs the Dialog Flow part. the problem comes when we connect with the process through the connector :slight_smile:
That’s why you are getting that error

Thanks. I changed the argument type to datetime which was string before. The chat bot seems goes and says ‘Working on it’. But the process is started in Pending state. PFB the image


Why is that. I have configured Studio bot to Orchestrator. When i run manually from Assistant it works.
Here is the screenshot for Map in Connector

Thanks in Advance. I really appreciate it :slight_smile:

1 Like

Thanks @manishjagtap. Amateur mistake :slight_smile:

2 Likes

why it is in pending state is because your robot type is not set to unattended…

go to your robots page in Orchestrator, and change the robot type to Studio to Unattended and run the job again

1 Like

Thanks @Lahiru.Fernando I got it to work. Really appreciate it. Just one more question. As we are creating a chatbot connection right. When i logout the connection disappears. Please let me know how can i resolve that. Thanks :slight_smile:

1 Like

hmm… That’s weird… It should not happen… I just created a new one and it worked fine for me… I will check again and let you know

2 Likes

I have followed the tutorial and can get the chatbot to say ‘working on it’. In my Jobs tab in Orchestrator i can see the following as per screen above.

Eventually the ChatBot says please try again later and i need to kill the job in Orchestrator.

I checked and the username argument are both string and the dates are System.DateTime.

Any ideas what I am doing wrong?

Is it going in pending to allocation state?Please make sure your bot is unattended and configured properly with the same domain/username and as your system password.

1 Like

@ashishsinha1504,
Yes on the Jobs section it has the value ‘Pending Allocation’ for Robot and User columns.

I readded the robot so sure it is using my correct domain/username and password. It add it as unattended.

In my UiPath workflow in the MessageBox I have:

“User entered name” + UserName + " and entered date" + UserDate.ToShortDateString()

Is the ToShortDateString correct?

I will try removing the process and robot and adding it again. I am just running from my local machine should i be able to see anything in the robot tray or not as it is unattended.

Is it possible to share the xaml from the workflow used in the demo?
Thanks.

Yes you should see the process in robot tray. As you said it’s showing pending so it means your robot in not configured properly. Remember to create a robot as unattended. Assign this robot to your environment. Go to cmd prompt and type ‘whoami’ copy this and paste into domain/username section. Use the pwd as your computer pwd. It’s not the workflow issue it’s configuration issue. Also day.tostring will work fine. Let me know if it works. Otherwise upload a video on drive and share the link with us we could see what’s wrong. But I would recommend to do the configuration properly.

1 Like

Thanks @ashishsinha1504 I will try your suggestions later today.
Thanks again for your support.

1 Like