Trying to insert string variable into browser based app textbox. But something is going wrong

I captured from Excel two variables. I am sure they were captured because I checked it, by inserting a Message Box displaying the content of the variables.

The browser app in question has a filter which I already saved with some inputs. So the normal flow is to click Filter Edit. A new screen shows, with two input boxes, one for Doc Name and other for Doc Version.

Again, normal flow is I click the box. Then I select and delete the text in the box and paste the new text. Or I click before or after the text in the box, and press either del or backspace.

So, at the UiPath flow I enter the Edit Filter and I have the new window.

I first tried “Type Into” and clicked over the input box and also selected Empty Field. Saved. Edited the ‘Type Into’ activity by typing the name of the variable inside the “Text” field. I did not use any quotes. Just wrote varDocName.

When running the flow, at that part nothing happened. The input boxes in the app do not have their content deleted nor the variables content gets pasted.

Tried adding a CLICK action before “Type Into”. But it did not work either.

Any idea on what I am doing totally wrong?

wich browser are you using? I read that chrome had some issues … if you are using that … I will suggest change it and try with another one.


Can you please verify once that you put data insertion ( type into etc.) in attach browser activity.

If possible , share a screenshot with us.

Ok people. Solved it by selecting option “Send WindowsMessages”. Also unchecked the “Activate” checkbox.

It is now working.

But I am stuck in another part of the workflow.

The same app has a big right side toolbar where several icons are outside the view. To select items “outside the toolbar”, I must either hover the mouse for some seconds over an down arrow OR I can scroll down.

I tried the hover function to no avail however.

1 Like

try this.

Thanks VirajN, but unfortunatelly, Scroll Activity did not work. I hover the mouse over the correct element, then I tell Scroll Activity to scroll down… no matter how many pixels I tell it to scroll down, it scrolls just some 35 pixels, meaning I can´t see the icons way down in the toolbar.

just to be sure… I was able to use click over the stupid scroll arrows of this toolbar. They are not standard arrows however. And they work either by just clicking them or hovering them.

But UiPath behavior with these arrows is erratic.

Sometimes I run the workflow and I am able to scroll to the very bottom and then select the correct element in several loops… then in ONE random loop, it does not scroll all the way down or up, and then UiPath selects the wrong element.

It’s a toolbar. So the elements are ALWAYS the same (at least in this particular screen). Maybe there is a way to tell UiPath to click directly on a element, without scrolling to see it before?