Trying to get mail from Exchange Online using GetExchangeMailMessages and Office365 settings

In proparation to moving the whole Exchange setup moving from on-premise to cloud, I am trying to get e-mail from an Exchange Online mailbox in our organization, with a user consent setup, where the robot is identifying the user via username and password (AuthenticationType = UserNameAndPassword).
I have created an “application” in the Azure Portal with the permissions I would need to retrieve mail

.

Seemingly I have been able to a consent sent to Azure via other means (doing the user consent in a browser window, and seen it go through on the Azure)
Although I have specified ApplicationId and DirectoryId of my application. I still get a “Message. AADSTS65001: The user or administrator has not consented to use the application with ID ‘myID’ named ‘MyApp UiPath’. Send an interactive authorization request for this user and resource.”

I am using the following url to get user consent (and variations, since I am not entirely sure, which one worked):