How to solve the error The UiPath Excel Add-in installation failed or the AddIn has been disabled by Microsoft Excel due to policy settings. Please check its status by going into the "File | Options | Add-ins" or "Trust Center Settings | Add-ins" in Microsoft Excel?
Issue Description:
When using Excel activities from the UiPath.Excel.Activities package, some RPA users might encounter an error that states:
The UiPath Excel Add-in installation failed or the AddIn has been disabled by Microsoft Excel due to policy settings. Please check its status by going into the "File | Options | Add-ins" or "Trust Center Settings | Add-ins" in Microsoft Excel.
Root Cause:
This error arises when the UiPath Excel add-in is disabled at the registry level(the ProgID of the add-in was set to 0 at HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\OFFICE_VERSION\Outlook\Resiliency\AddinList) on the affected machine(s). In Office 2013 and newer versions, the programs offer add-in resiliency, which means that an add-in is disabled if it is slow in performance. Nonetheless, users can re-enable the add-ins and avoid auto-disabling by other office programs. More details here.
Resolution Steps:
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Locating ProgID of UiPath Excel Add-in:
To find the ProgID of the UiPath Excel Add-in, check the system registry at these two locations:
An example might look like: Computer\HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\Addins\UiPath.Integration.ExcelAddIn
- HKEY_CURRENT_USER\Software\Microsoft\Office\Excel\Addins
- HKEY_LOCAL_MACHINE\Software\Microsoft\Office\Excel\Addins
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Update Office to the latest build version and restart your PC.
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If an old Studio version is used, uninstall UiPath Studio and the UiPath.Integration.ExcelAddIn (if installed) from the Control Panel.
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After the uninstallation, restart the PC.
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Install the latest version of UiPath Studio or build and make sure to include the Excel add-in in this installation.
Note: If the UiPath Excel add-in was not installed during the Studio installation, it can be later installed from Studio → Tools → UiPath Extensions → Excel Add-in.
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Make sure to perform the following steps as an Administrator without skipping any steps:
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Download the Office Repair Tool from here.
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Extract UiPath.MicrosoftOffice.Tools.zip file to a location where Full Control access is granted and run the ".exe" file as an Administrator.
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Follow the instructions shown in the tool to generate a repair plan and run repair actions.
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Restart the PC, open Studio/StudioX as the Administrator user and go to Tools → UiPath Extensions → Excel Add-in → Install.
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Restart the machine after the installation.
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- In regedit as Administrator:
- navigate to Computer\HKEY_CURRENT_USER\Software\Policies\Microsoft\Office[OFFICE_VERSION]\excel\resiliency\addinlist.
- Add a new String Value named UiPath.Integration.ExcelAddIn with a value of 1.
- 0 = always disabled (blocked)
- 1 = always enabled
- 2 = configurable by the user and not blocked by the Block all unmanaged add-ins policy setting when enabled.
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Verify that the UiPath Excel Add-in is successfully installed and can work with it in Studio/StudioX. If everything is configured correctly, a corresponding message in the Studio/StudioX should be seen.
Example:
The details of the UiPath Integration for Excel should appear under Excel -> Options -> Add-ins:
In the end, if everything is configured correctly, a similar message can be seen in Studio/StudioX.
Remember to refer to the root cause verification steps to prevent the recurrence of this issue.
For more detailed info on keeping add-ins enabled, visit the here.