Troubleshoot Intermittent SAP Logon Activity Failures

How to troubleshoot intermittent SAP Logon activity failures?

Issue Description:

SAP Logon activity randomly fails to load the logon window. The issue is not reproducible on demand. Also, sometimes an error is thrown even though the window is opened.

Root Cause:

During failures, SAP reports that no sessions are opened in the newly opened connection.

Resolution / Workarounds:

  1. Modifying the properties of SAP Logon activity to retry the action to give ample amount of time to the application for launching the window:
    • Increase the RetryInterval to a higher value
    • Increase the NumberOfRetries to a higher value
  2. In case an error is thrown despite the logon window is opened, validate the same via the Element Exists activity and set the SAP Logon activity's “ContinueOnError” property to true.
  3. On the SAP Login activity set the target window to one based on the selector (from indicate on screen) as opposed to the one provided as output from the SAP Logon activity.