Trouble clearing assignment 2 on advanced course

I have completed and submitted my last assignment and it keeps telling me I have failed it, but without specifying what I did wrong. Seems to me all the work items are correct… how do I figure out what is wrong?

Hi @lisbeth.skogland
have you let the process finish running on the whole WI ?
if so you have to let the data as it is “no Reset Data” .

Yes. It is all there and it seems ok. Work items are marked completed with the upload id in the comment field. However, I do see in the specification that it should say “Uploaded with id …”. Could that be it? Has the whole thing failed because of that?

Just thought I’d ask… what do I do now? Should I leave it without resetting the data? Will someone look into it?

Between the process getting finished and the upload of the performer you should not reset the Data, also your the items in the queue should be marked as completed, this is how it worked for me

I did those things. Items are marked as completed and I didn’t reset the data. Still haven´t. However, it does not tell me what is wrong. I could just do the whole thing again, but I don´t see how the result would be different.

Without any indication of what made the items failed, it is virtually impossible to figure out how to pass it…

Any way of getting in touch with a human who can review this or something?

One last question though does it give you always 0/100 or it’s different each time?

Just uploaded twice. Gives me 0/100 both times.

ok @lisbeth.skogland don’t get frustrated I did submit so much times before getting the certification and it turns out that the problem was I didn’t run the process on the whole WI, anyway I will suppose that you have obeyed all these requirements

  • Status Completed(on the acme and the orchestrator queue items as well)

  • Filename that was uploaded = “Yearly-Report-2017-[TaxID].xlsx” (Exact filename)

  • Yearly report contains all available monthly report information (merged file)

  • comment contains the correct Upload ID (so important)

in this case I will ask you to see the following link

make sure your problem isn’t with the credentials that you provide.

Ok. So it checks the orchestrator too. That might be the issue then, as I used a different name for the queue. Guess I need to fix the queue names and rerun. In the Filename the “[” and “]” aren´t supposed to be in there right? Everything else seems ok to me…

Frustration level rising…

Ran through the whole thing again. Changed the queue name and the comment text. Then all of a sudden I got 7/100???

How is that even possible? Robot is supposed to do the same thing to all items and if I got some correct I should have gotten most of them correct. A couple failed, which is fine. But still…

And since we are getting NO FEEDBACK AT ALL about what is wrong, it seems like this is pure lottery really

Hi @lisbeth.skogland
You still facing the same problem?

Yes, basically given up on it though.

imagine having a customer who you work for and has given you an assignment. You work on it for a few weeks, or months even and then he says “naaaah, that´s not what I want” but without specifying what is wrong with what you have done at all.

That´s kind of how I feel about this. I have basically spent more time trying to fix this then I did making it in the first place and I may even have broken more than I have fixed and I have no idea. Obviously we are not talking about weeks or months, more like hours. But still feels like wasting my time.

I figure if the robots testing this is actually testing criteria, it can´t possibly be that hard to give concrete feedback about what criteria made it fail, right?

Well, I think you already know this, but when you start seeing 7/100 that means only some items were completed in the right way, the solution for me was to reset the data and run both
The dispatcher to fill the work queue in orchestrater and then the performer
And then the elements should be marked as completed in the orchestrator as well as acme

Yeah, well I did…

Same result. Makes no sense what so ever. They are marked as completed in both systems. And it takes time to run this which keeps my computer busy.

I don´t see the point of going on searching for the needle in the haystack. My robot does the same procedure with all items, so I can´t find any good reason I should get ok on some but not the rest.

I will just go on to the certification test which will make this course less relevant anyways. I do hope for the sake of others that the feedback becomes more concrete though

Well, I think this is a good idea

once you played enough with the advanced training, the certification will look easy actually
good luck…

one last thing can you upload a zip file of both the dispatcher and the performer that you’ve made I want to take a look at it after.


Yes you can upload both dispatcher and performer both in one folder.
Just a add dispatcher and performer in one folder and right click on that folder for add to archive when you are submitting assignment.

Just sharing my experience from assignment 1. First time my score was 0/100 and the reason was I reset test data before evaluation was complete. I hope you are not doing the same mistake. 2nd point please check if all WI4 work Item status are marked complete with exact Confirmation ID. Match the confirmation Id from video with your output updated. 3rd point check if the merged results of monthly reports to yearly report is correct and with correct naming convention.

Hi, @reda,

when you say set the queue items as “Completed” on the orchestrator, how does one do that? I can only see options to set transaction status as “Successful” or “Failed” in the Studio? What are we missing? I have read through the thread & have done everything described, only part I do not understand is your response around “Completed” for a transaction item on the Orchestrator as well, how does that work?

Thank you in advance.

Hi @MphaKheswa

I meant Status Successful , note if you’re using the ReFramework this is done by default in the setTransactionStatus.xaml workflow, so you don’t need to do this manually.


1 Like