Trouble activating license

Hi,

I’m using uipath for a few months now but so far i’ve always executed tasks locally with the license my company gave me.

I now have to setup an unattended robot on a virtual machine but i have issues with my license. The virtual machine has the license locally but i can’t seem to find a way to activate the license on my account so that i can connect Orchestrator to it.
When i’m trying to connect to Orchestrator it says “connected, no license”.
Also when i’m trying interactive signin after i’m connected, i have an error saying :
“IUserOperations.SignInCore threw System.InvalidOperationException: “Error loading discovery document: Error connecting to https://cloud.uipath.com/identity_/.well-known/openid-configuration. An error occurred while sending the request…”.”

Any ideas on what this error is about ? And is there a way to activate license on an account ?

Cheers

Hello @robin.tessier,

It seems like your virtual machine agent is able to connect to orchestrator. But their are no licenses available Please follow below link to activate license,

Hell @Vish2148,

I’ve already tried following this documentation page, but the thing is I only have UiPath Studio and Assistant. On the web orchestrator, I didnt find anything on the licence’s tab to activate it.
By the way on my personnal computer, it says connected with licence but not on the virtual machine :frowning:

Thanks for your help

Hello @robin.tessier,

Do you want the license to be on Virtual Machine or your personal computer ?. As you said in Virtual machine Agent shows connected and not licensed might because the license has been allocated to your Personal Computer.
I think you have a modern folder orchestrator if it is you can check the machine licenses under Tenant–> Licenses and click on “Unattended” to see the allocated licenses to machines.

Hi @robin.tessier,

Could you please share which license type have your activated for your account?
to check this, please go to tenant->machines->select your machine name(that you have configured)->click on edit, below screen opens, check which license type have you assigned, it should be unattended for prod, non-prod for non-prod env.

And then also check status of your license in licenses tab, is it green or red?

Also, can you please go to your command prompt on the machine you are trying to run the unattended process on, type “whoami”, and paste that domain\username for the unattended bot in the user settings as seen here and enter the windows password under “password”:

Please check all these settings, correct if not as mentioned and then try to connect, it should work.

Regards
Sonali