Tried to install a dependency by mistake, now all my flows give me "L Value Invalid Expression..."

At this topic, UiPath copies number from Excel as 1.000,00, pastes in web browser as 1000.00, @aeklof suggested I run the activity Message Box with “Cultureinfo.InstalledUICulture” inside.

I did not properly understand the suggestion and tried to install the package package System.Globalization 4.3.0 to have this CultureInfo activity.

However, I got an error trying to install this package.

And worse. After installing, it, now my all my UiPath flows have errors. It started immediatelly to give me COMPILER errors after I tried installing that package:

And I am getting these weird "L value invalid expression. The reference expressions cannot end with a conversion. The type of given expression must coincide exactly with the type T of VisualBasicReference or LambdaReference

image

Searching the forum for similar errors the best I got was a suggestion of deleting variables, recreating them again and assigning them again.

But not only that gave me major headaches in flows with tons of variables, as I have this other flow where even that is not working.

Any suggestion??? Reinstalling UiPath?

ps: I deleted the uncorrectly installed package (that was being shown in red) and re-started UiPath multiple times as well as rebooted the system.

HI @Rogerio_Penna

Get a backup of your UiPath solution…
Next, keep a note of your dependencies that already exists and delete the project.json file. Now, double click on your main xaml file to open the solution. This will recreate the project json file.

Once the solution is open, check whether your errors are gone

let me know how it goes…

Before you do anything, I just want to remind you to take a backup :slight_smile:

Thanks Fernando.

“Get a backup of your UiPath solution…”

hmm… how exactly? What should I copy?

“Next, keep a note of your dependencies that already exists”
these?

Yes… now just delete the project.json file…
double click on the main xaml file and open the solution. This will recreate the dependecies you have listed here… So basically if something went wrong in the project json file, those should go away hopefully…

did not fix it.

but it’s VERY WEIRD. Sometimes, when I put the cursor over the “!” icon, I get the error message I posted above.

Other times, I get THIS message (from the same “!” icon…

“It’s not possible o add a second reference to xyz.dll”
“The project already has a reference to the assembly”

@Lahiru.Fernando Do you think it would be possible/better to just uninstall and re-install UiPath?

@Rogerio_Penna

This is weird… yea… you can try uninstalling and reinstalling uipath as well…

uninstalled and re-installed. No use. Well, I guess the problem is inserted somewhere deeply in the xmla file itself?