Transferring machine on Orchestrator CE

Hello everyone,

I started working on the Orchestrator CE a few days back. The initial setup was complete and I started running tasks and scheduling them as well but now I am thinking that I don’t want these tasks running on my main laptop, I have another laptop which can be used for these tasks, I found out that I can run the tasks on my main machine if I log in to Orchestrator from a different system, but my goal is the opposite, running tasks on secondary machine which I can manage from the main machine as well.
But after several steps I ran into an issue while connecting my robot to the new machine in Orchestrator on the secondary system, which says “The server did not provide a meaningful reply; this might be caused by a contract mismatch, a premature session shutdown or an internal server error.” while the robot stays disconnected. Before doing this, I made sure about removing the old robot, environment, machine and all the processes as well.

Sorry for writing such a big story. Please let me know if someone can give me any information which can help me change the system.

Hi @Pratishthit

It shouldn’t be that complicated at all. I assume you use the Studio CE. You should install it on both machines, then connect your Robot on each machine to the Orchestrator CE. Then you will be able to see robots in the Orchestrator.

If I understood you correctly, you will then be able to develop and publish from one machine and then use the Orchestrator CE website (from any machine you want) to schedule the job to be executed on the other machine.

I hope it makes it a bit clear :slight_smile:

Hi @loginerror, thanks for your reply.

Yes I am using the Studio CE, and running the studio on another machine is working, no problems in that area.
I tried this already, I created a new robot with a new machine and tried to connect the robot to the Orchestrator and I receive the error as shown in the image below.

This is where I am stuck right now.

Thanks
Pratishthit

Hi @Pratishthit

Please try either of the two solutions:

  1. Both msi and community exe are installed → remove both and install only one
  2. Community did not install properly. Just give it a reinstall and a computer restart and it should be fixed.

Hi @loginerror

Thanks for that, it worked now, I added a new robot and a new machine and the robot is connect, but this new robot is unlicensed and jobs are not working on this system, while the previous system robot still says licensed.
Does this mean I can keep only one machine per community version license?

Thanks
Pratishthit

You should be able to connect two development robots to the Orchestrator.

Does the currently unlicensed robot become licensed when the other is disconnected?

2 robots can be connected, but they are connected to 2 different machines.
And yes once I remove the previous robot, the new one becomes licensed.
So that means

this is correct?

This is strange, as I have similar setup and I have two machines connected at the same time and both robots are fully licensed. For that you have to have two robots and two machines, each robot connected to the appropriate machine.

@loginerror Thanks for your help, I got it running now. The fix was to have unique usernames for the robots.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.