Trace Level Logging Not Reflecting When Running Jobs In Cloud Orchestrator

Why are trace level logs not getting reflected when running jobs in Cloud Orchestrator? Why even after setting the logging level in the UiPath Assistant, Trace logs not getting generated in Cloud orchestrator ?

Issue Description: Trace level logs are not getting reflected in Cloud Orchestrator --> Logs tab for Unattended jobs.


Root Cause: Logging Level from Tenant \ Manage Access \ Edit Robot User \ Robot Settings was set to Information.

Resolution: In situations like this when the trace level logs are not displayed in the Logs tab in Orchestrator, the below needs to be verified.

  1. Check that there are any filters applied that may limit the logs level that are displayed
  2. Check that the Robot machine has enough disk space
  3. Verify if the logs are saved into the local log file from the Robot machine (If yes, this means that there is a connectivity problem between Robot and Orchestrator)
  4. Restart the Robot service and check the Orchestrator logs tab
  5. Verify the logging level set in UiPath Assistant

If all the above steps do not lead to a communication or log collection problem, check the below setting as well:

  1. Go to Orchestrator \ Tenant \ Manage Access \ Edit Robot User \ Robot Settings and make sure that the Logging Level is set to Trace and not to Information.

  1. After modifying the above setting, Trace logs should be displayed in the Logs tab.