TPOT XGboost classification train error

Hi all,
I’m trying to train the TPOT XGBoost out of the box classification model. One of the environment variables is train_time which is set by default to 2 minutes. I’ve tried changing this when starting the pipeline, however I get the following error:

Traceback (most recent call last):
File “/usr/local/lib/python3.6/site-packages/tpot/base.py”, line 711, in fit
per_generation_function=self._check_periodic_pipeline
File “/usr/local/lib/python3.6/site-packages/tpot/gp_deap.py”, line 227, in eaMuPlusLambda
population[:] = toolbox.evaluate(population)
File “/usr/local/lib/python3.6/site-packages/tpot/base.py”, line 1287, in _evaluate_individuals
self._stop_by_max_time_mins()
File “/usr/local/lib/python3.6/site-packages/tpot/base.py”, line 1205, in _stop_by_max_time_mins
if total_mins_elapsed >= self.max_time_mins:
TypeError: ‘>=’ not supported between instances of ‘float’ and ‘str’

There is obviously a mismatch of variable type here, however it looks like its an issue with the maximum training time that I’ve set (from what I can tell).

Is there a way that I need to set the variable as a float or something else that I’m missing?

Thanks

Hello @Tom_Jeffries!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly
Forum_Staff

Bumping this topic since I’m struggling with the same issue.
The model can complete a full pipeline when no train_time argument is given. However, I would also like to experiment with higher training times.